Jump to content
Sign in to follow this  
QMax

Far Cry 2 Problems

Recommended Posts

Alright, I've had Far Cry 2 since it came out, and I had no problems with it before. I recently ran it again, and at first it would not even get past the first loading screen.

 

I updated my video card driver,verified the game files and defragged it (Steam).

 

Now this is what happens. I play the game, about every 5 minutes the game freezes and goes not responding. I can open task manager and after about 15 seconds the game starts responding again and I can continue playing.

 

You can imagine how frustrating this is.

 

Any ideas?

Share this post


Link to post
Share on other sites

Anyone with technical expertise, I would appreciate your response. Thank you

Share this post


Link to post
Share on other sites

Sounds like it could be power supply or temperature related?

 

It would help the forum members considerably if you could post your complete system specs.

 

Cheers

 

Paul

Share this post


Link to post
Share on other sites

ASUS p5n-d motherboard

Q6600 Core2Quad 2.4Ghz (no overclock)

OCZ 620W

4gb Ram (not sure make)

Nvidia 9800GTX+ (driver version: 191.07)

Vista Home Premium 64x

 

Anything else you need?

Share this post


Link to post
Share on other sites

Friend of mine haad that same issue. He had to edit the start up command in steam to start on DX9 instead of 10. He also was running VHP 64 bit.

Share this post


Link to post
Share on other sites
Friend of mine haad that same issue. He had to edit the start up command in steam to start on DX9 instead of 10. He also was running VHP 64 bit.

Or you could just choose DirectX Version 9 in the Graphics options, im sure FC2 has that option in there somewhere, try that and see if it still crashes

Share this post


Link to post
Share on other sites

Did you patch the game? Turn up gpu fan speed?

 

 

If nothing we suggested works get a DMM to test the psu.

Edited by Ste

Share this post


Link to post
Share on other sites

GPU fan speed is always manually changed before playing a game. My 9800GTX+ has a problem of not automatically increasing the fan speed enough during intensive gaming. It will rise above 100C if not changed; but I don't think this is the problem, it has only gone above that temp 3 times to 103,108, and 114 C, which is pretty hot, but managable for the card in a short period of time.

 

It does work fine with any other game (ones that run the card even harder), I will try the DX9 option and see if that works, I'll get back to you on that.

 

Probably just a coincidence, but this is the only game I have with SecuROM.

 

 

Update: The game works fine now; although I didn't even switch it to directx9. If there is a problem in the future (like maybe next time I play it), I'll try that.

 

Thanks for everyone's input.

Edited by QMax

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...