Jump to content
Sign in to follow this  
Chrusty

Terrible issue with the HD 4890

Recommended Posts

I just installed the HD4890 into my current rig and am having awful issues with it.

 

1. This is probably the most worrying issue, I am getting a serious electrical buzzing noise whenever the card is slightly under load, like when playing HAWX. It's a very loud noise and sounds pretty serious.

 

2. There is a different noise I also get, of a higher frequency and pitch but similar to the other noise, I get this one when I scroll web pages fast, haven't really noticed it anywhere else yet and I have heard that it is a common and unavoidable issue.

 

The main issue I am worrying about is the loud electrical buzz from point 1. It is very worrying and I would love if anyone here had a solution. Thanks.

Share this post


Link to post
Share on other sites
I just installed the HD4890 into my current rig and am having awful issues with it.

 

1. This is probably the most worrying issue, I am getting a serious electrical buzzing noise whenever the card is slightly under load, like when playing HAWX. It's a very loud noise and sounds pretty serious.

 

2. There is a different noise I also get, of a higher frequency and pitch but similar to the other noise, I get this one when I scroll web pages fast, haven't really noticed it anywhere else yet and I have heard that it is a common and unavoidable issue.

 

The main issue I am worrying about is the loud electrical buzz from point 1. It is very worrying and I would love if anyone here had a solution. Thanks.

it'd be normal if it was doing it during folding or something but mine doesn't do that when playing games, does everything work find other than that??

Edited by IVIYTH0S

Share this post


Link to post
Share on other sites
it'd be normal if it was doing it during folding or something but mine doesn't do that when playing games, does everything work find other than that??

 

Yes everything seems to be working OK other than that. I want to avoid RMA'ing the card if possible, as I have had to RMA parts of this rig already and this is the first time it has booted up in 2 months without any problems, until now, of course.

Share this post


Link to post
Share on other sites

hmm do a stability test with ati tool if it doesn't artifact and you don't want to RMA then just turn those speakers up

Share this post


Link to post
Share on other sites

I've tried the rig in a few different outlets around my house and i've also used different socket boards, to no avail. It isn't a squealing whining noise, I get that with most graphics cards I use, it's a distinct electronic buzzing. It happens during both the game menu and the game itself, basically whenever there is any 3D that is putting the card under load.

Share this post


Link to post
Share on other sites
squealing is a sign of "dirty" power, but it isn't always the case.

 

It happens even when plugged into a UPS.

 

I've tried the rig in a few different outlets around my house and i've also used different socket boards, to no avail. It isn't a squealing whining noise, I get that with most graphics cards I use, it's a distinct electronic buzzing. It happens during both the game menu and the game itself, basically whenever there is any 3D that is putting the card under load.

 

SO this is not the normal squealing then! If so that may be something more severe and would warrant an RMA. Have you tried isolating the sound on the GPU pcb to by probing with a non conductive tool! Could be a choke vibrating!

Share this post


Link to post
Share on other sites

is the sound coming completely from the card?

 

i have a lead coming off my sound cards line in into which i plug my 360 to run the sound through my PC speaker setup. if i leave the 360 plugged in when it's not in use, and the volume is turned up it generates a lot of noise, which for some reason is greatly effected by GPU load (including web scrolling).

 

even without that lead, using my onboard sound i get the same speaker noise at high volumes, and in both cases it sounds a lot like coil whine. i remember running the cryostasis benchmark and hearing the noise change in pitch exactly in line with my framerate.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...