Jump to content

Windows 7 imaging


Nodgiles
 Share

Recommended Posts

I create the images for my company and Im starting to do so with the RTM of windows 7. Im struggling, and Im sure many of you are as well. Im going to share some notes that Ive made in hopes of helping you, and perhaps you all can help me.

 

Creating a default profile:

 

As far as I can tell this can only be done with using sysprep, this is new to win7. What I have done is used AIK and created a xml file using the copy profile in the specialize pass.

 

<?xml version="1.0" encoding="utf-8"?>

<unattend xmlns="urn:schemas-microsoft-com:unattend">

<settings pass="specialize">

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<CopyProfile>true</CopyProfile>

</component>

</settings>

<cpi:offlineImage cpi:source="wim:c:/documents%20and%20settings/altirisadmin/my%20documents/windows7rc-imaging-files/files/sources/install.wim#Windows 7 PROFESSIONAL" xmlns:cpi="urn:schemas-microsoft-com:cpi" />

</unattend>

 

save the xml file in c:\windows\system32\sysprep

 

then run the following command from a command prompt: sysprep.exe /generalize /oobe /quiet /unattend:nameofanswerfile .xml

 

 

 

If anyone has any additional imaging tips, tricks, or comments, Id love to hear them and share experiences.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...