Jump to content
Sign in to follow this  
xPETEZx

Bioshock

Recommended Posts

Hi!

 

I recently purchased Bioshock on Steam, as it was the most highly rated game on Metacritics, and everyone I spoke to that has played it, had only good words for it.

 

So I downloaded and installed it. Only to be ment with an instant blue screen. I rebooted, and started the game. This time, no blue screen. I assumed it was a one off.

 

The next day I went to play again. No problems. I then later played other games, including Left 4 Dead and HL2:DM. As soon as I then tried to play BioShock, I got another blue screen.

 

To cut a long story short, it appeared as though Bioshock would cause a blue screen if I played another Steam game before playing BioShock.

 

I assumed the issuse was to do with my Razer Barracuda AC-1 sound card, as just before each crash, a very annoying and loud screech would come out of all the speakers. I was looking to get an ASUS Xonar D2 later this year for 7 (as the AC-1 dosent seem to have 64-bit drivers :wacko:) So upon getting the Xonar, I tested again. Only to be met with the same problem.

 

If I turn ON EAX sound in the game, the game will cause a Bluescreen when I try to quit, as opposed to when I launch the game. It will take me back to desktop, but as soon as I do anything, like start Firefox, or even click on another application, the screech sound plays, and shortly after, my PC blue screens.

 

I have been in touch with Steam support (they have been AWESOME!) and they seem to think it could be a sound card issue. This seems odd to me, as 2 totally seperate cards have done this. Before buying, I was told the Xonar had excellent drivers, hence why I choose it over the Prelude, which I am told has somewhat ropey drivers. (I have had enough sound driver problems with my AC-1, so I wanted 100% solid drivers) and till now, I have had a good experiance with the Xonar and its drivers. Bar this.

 

Since I last formated this PC back in June 2008, I have not had a single Bluescreen, or hard system crash requiring a restart. In the 5 days I have owned Bioshock, I have had about 8 blue screens already. so I am more than a little annoyed!!

 

I am very close to asking steam to refund me my money, and take Bioshock off my account (is this possible?) cause a game I cant play without risking Blue screens, is no good to me.

 

I have also opened a ticket with T2 the developer of Bioshock, to see if they can assist.

 

In the mean time, anybody got any suggestions?

 

All my drivers are up-to-date and its running on my main Rig. AS I said, I have tried 2 sound cards so far, and both exhibit the same problems.

post-14164-1243023412_thumb.jpg

Share this post


Link to post
Share on other sites

Seems like a software/driver problem (usually the case with stop errors), but I have gotten stop errors while running an unstable OC. Have you tried running it stock?

Share this post


Link to post
Share on other sites

Are you running the latest Xonar drivers?

Is GX mode enabled on the Xonar?

Are you running onboard audio as well (is it enabled in BIOS)?

Have you tried downloading the latest DirectX Runtime and installing it?

Share this post


Link to post
Share on other sites
Are you running onboard audio as well (is it enabled in BIOS)?

:withstupid: If it is truly a soundcard issue, this is the first thing you should check. If you don't manually disable onboard audio in the BIOS, that can certainly cause conflicts, although I'm surprised you wouldn't have already encountered some. This would also explain why testing a second soundcard didn't "fix" the issue.

Share this post


Link to post
Share on other sites

Thanks for the replies guys!

 

I have never had the On-baord enabled since I built this machine. One of the first things I did in the BIOS. So no, there is no other sound device installed other than the Xonar.

I have the latest drivers, bar a Beta driver for it.

 

As I said, the same thing happened with the AC-1 card. Which is what makes me think it must be something else other than Sound drivers??

 

I am not sure how to enabled/disable GX mode for the Xonar. :( I cant find an option in the drivers. (the Steam guys asked me to try that too. So if anyone knows where to find this setting, that would be great! I already searched all the dialougs in the control panel)

 

Ill try getting the latest DX 9 runtime and see from there.

 

Thanks for the suggestsions!

Share this post


Link to post
Share on other sites

I'd say reinstall your OS...but with Vista64 instead! Trust me, Bioshock in DX10 is amazing, and as long as the Xonar card has Vista drivers, you have the specs to run it very nicely.

Share this post


Link to post
Share on other sites

:P

 

I'm gonna hold up till 7 now. :)

 

So, perhaps, ill just let Bioshock rest till then. :( Shame! Was really starting to get into it!!

 

The Xonar has drivers for everything :P thats why I got it! Was feed up of the Barracuda, it had ONE driver update in the time I owned it (2yrs +) and NO 64-bit drivers. (that I could find)

Share this post


Link to post
Share on other sites

I read through and I didn't read anything about uninstalling BIOSHOCK and reinstalling it.....? You have probably already done this but I figured id check and see...

 

:)

Share this post


Link to post
Share on other sites

Seeing as its a Steam game, I havent actually tried.

 

I am not sure how I would? I guess delete local content, and then wait for it to Download again?

 

I guess there is no harm in trying. Seeing as perhaps there was some kind of DL error? May try clearing local content, and getting to re-download it later tonight.

Share this post


Link to post
Share on other sites

Hmm, if you're wondering if you're having trouble with your sound cards (IRQ conflict, perhaps - check your event viewer), you can always try onboard and see if anything changes.

 

I haven't had a single problem with Bioshock, downloaded straight from steam, but, I'm running Vista x64 Business.

Share this post


Link to post
Share on other sites

Hmm I have never DL straight from steam.... I have Empire Total War, which is a steam game.... I installed it from a cd and It has and uninstall option like any normal program...

Share this post


Link to post
Share on other sites

http://razerblueprints.net/index.php/compo...e/topic,6637.0/

 

Check that out.

 

Any steam game will un-install just like anything else

 

Your problem is definately a directShow issue. I'll bet $1 that there is a single codec causing ths problem but I don't have any more time to dig into this. I have to go down to Calgary and trailer my 2005 Dodge ram 3500 that is short a bumper and rad/cooler/intercooler!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×