Jump to content
Sign in to follow this  
GaiusMaxwell

Power Supply Or Motherboard Problem?

Recommended Posts

Just came over to have a look at a mates computer, he shut it down, went to bed, woke up and it wouldn't power on

 

Power is in and a green light is lit on the back of the generic psu, press power and nothing happens, psu fan doesn't spin, nothing makes a noise, nothing at all

 

Mains connector is plugged in, so im wondering if its the psu or the motherboard?

 

Or something else but I kind of narrowed it down to either of those

Share this post


Link to post
Share on other sites

i would just like to add the only time its ever been tampered with was when i replaced the 7600gs with an 8600gt, its been working fine for about 6 months, this just sort of happened out of the blue

 

its relatively clean, a bit of dust but thats expected after 2 years

 

More info on the psu its a 300watt unit from a brand called "hipro" its looks like a cheap generic, when the power cable is plugged in a small green light on the psu lights up, im guessing to tell us that it is recieving power, does this mean the mobo is dead?

Share this post


Link to post
Share on other sites

Try using another psu. You're gonna have to do some trouble shooting to find the culprit. I'd take a guess it's a bad psu.

Share this post


Link to post
Share on other sites
Try using another psu. You're gonna have to do some trouble shooting to find the culprit. I'd take a guess it's a bad psu.

 

yeah im guna have to take the thing home now

 

Thanks raider

Share this post


Link to post
Share on other sites

If you have a psu tester, that will either mark the baddy to be the psu or put it in the clear...

 

Honestly, a psu tester is like $20 and it comes quite handy in times like these ;)

Share this post


Link to post
Share on other sites
i would just like to add the only time its ever been tampered with was when i replaced the 7600gs with an 8600gt, its been working fine for about 6 months, this just sort of happened out of the blue

 

its relatively clean, a bit of dust but thats expected after 2 years

 

More info on the psu its a 300watt unit from a brand called "hipro" its looks like a cheap generic, when the power cable is plugged in a small green light on the psu lights up, im guessing to tell us that it is recieving power, does this mean the mobo is dead?

Ye hipro is the make of PSU i got with my HP Compaq and you are correct when you say that the green light means it is getting power from the mains.

Share this post


Link to post
Share on other sites
Guest ajmatson

Search google on how to jump a power supply using pins 13 and 15 (green and black) to see if the PSU comes to life or not. That will narrow it down.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×