Jump to content
Sign in to follow this  
vyroburn

Radeon 4850

Recommended Posts

I just recently got a used radeon 4850 off the smith and all seems to be going well untill I load up WoW, This card is giving terrible frame rate and freezes up when making sharp movements. There is no way in hell it shouldn't be running 60frames at all time.

 

Anyone have any ideas ? I am kinda wishing I would have stayed with nvidia now =(

Share this post


Link to post
Share on other sites

No its disabled. I am getting worst frames with the 4850 than my old geforce 6800gs I have installed the 8.12 drivers, and I am using directX10 and windows vista.

Share this post


Link to post
Share on other sites

Sounds like Vsync would explain the 60fps, but I don't know about the freezes.

 

Nevermind, scratch Vsync then. Unless you have Vsync forced in CCC. Wait, does CCC have an option for Vsync? I don't remember.

Share this post


Link to post
Share on other sites

Have you removed all nVidia drivers? What power supply are you using?

Share this post


Link to post
Share on other sites

Did you use drive cleaner when you took out your nvidia stuff. I know of a few times where Nvidia stuff causes issues if something is left over. Maybe try a fresh driver install and see what happens.

Share this post


Link to post
Share on other sites

Uninstalled all the drivers, ran the drive cleaner, re-installed all the drivers, including the hotfix for gpu issues 8.12, directX 10, and Still terrible frames in wow, like 20-30 frames which is horrible.

 

I wish I just would have stuck with nvidia, anyone wanna buy this hunk of junk ?

 

screenshot.jpg

 

I dont understand in gpuz it says the driver version is different ? anyone have any experience with this ?

Share this post


Link to post
Share on other sites

Is GPU folding running in the background?

 

What resolution and how much AF are you applying on WoW?

Share this post


Link to post
Share on other sites

With a little Google help, I found similar problems to yours from other users. I doubt this will help, but try looking at this post specifically, or even the whole entire thread.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...