Jump to content
NeoDeGenero

Not Detecting An Ide Hdd In Windows Vista

Recommended Posts

Hi everyone,

I'm not sure this is the right place to post this problem, but i believe it may be a driver problem. Please move this thread if it is in the wrong place.

Thanks!

Spec List:

 

* OS: Windows Vista Ultimate x64

* CPU: Intel Core2Duo D6750

* Motherboard: Asus P5K-SE - latest BIOS

* RAM: Geil Ultra 4x1GB 4-4-4-12

* GPU: Raedon X-550

* HDD1: SATA WD Raptor 150GB (Primary)

* HDD2: IDE Seagate ST380011A 80GB (MISC/Torrent)

 

 

Problem: IDE HDD not being detected in Windows

 

A brief history of me and windows vista:

When Vista first came out, I obtained a Business/Enterprise Edition from work and decided to try it on my system. Unfortunately, like alot of people, i experienced quite a bit of problems, and the only reason why i went back to Windows XP Pro was because at the time Canon did not have a Vista driver/program for my laser multifunction centre.

 

So when the drivers/program did came out for vista (incl x64), I did no hesitate to format and install Vista Ultimate x64 on my system.

 

Problem #1(Solved):

First problem i encountered was that Vista did not detect my Pioneer DVD burner, and finally after some googling and registry tweaking, it was found that because i installed PowerISO that mucked up a few things. Smiliar problem happened to another user whom installed Daemon Tools. So that's solved *Phew* SOLVED

 

Everything was fine, except for one little thing that bugs me, in Vista for some reason, each time when i access the second HDD, it makes a click as if it was spun down, and was just spinning up when i was accessing it. Never happened in XP. So I was thinking it was maybe an Vista feature to save power. (Happens both times when i installed Vista)

Real Problem:

So everything was running smooth and such, and for some reason, about two days ago, my IDE Drive decided to disappear on me. After many attempts at trying to get it back, no avail, so i'm turning to you guys for help before I format.

 

Here's what I have done:

Disabled PowerISO

Uninstalled Marvel RAID Controller software (not sure what it was for, was in the motherboard CD)

Upgraded motherboard BIOS

Resetting motherboard BIOS to defaults (didn't pull out CMOS batt)

 

I also Went through all the device listings in Device Manager and manually force update all drivers.

 

Still it doesn't find anything, I went to the Seagate site, installed the detection software, and like my BIOS, it detects the drive. Ran the diagnostics tests on it, works fine.

 

I have attached a screenshot of my Device Manager, and the IDE controller is not present.

 

Any i ideas/suggestions before i format again would be greatly appreciated!

Thanks in advanced!!

 

ssaf7.th.jpg

Share this post


Link to post
Share on other sites

Does the BIOS see the drive?

If so:

Have you formatted the IDE drive?

Go to drive manager and format.

 

As to virtual drive manager, I use Daemon Tools for virtual drive because it doesn't do the funky stuff to the system.

Edited by Syngensmyth

Share this post


Link to post
Share on other sites

The first thing I'd do is check if the drive shows up in the BIOS. If it does, then I'd toss it in another computer to see if it shows up there.

Share this post


Link to post
Share on other sites

Hi, yes the bios detects it, Linux (Ubuntu) detects it, and the old XP detects it too.

Its just Vista doesn't recongise it, doesn't show up on Device manager, or HDD Manager. ><

Share this post


Link to post
Share on other sites

Hello,

 

You are correct about the hard drive power down issue, it is the power saving mode.

Go to the screensaver section >adjust power options (not using Vista anymore so not quite exact on the detail)

 

For the second issue

Go here, then press on driver and download the Marvell IDE drivers.

http://support.asus.com/download/download....;model=P5K%20SE

 

Not sure if this will help you but worth a try.

Also in device manager what happens if you do, view >show hidden?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...