Jump to content
Sign in to follow this  
timmytoes

I strayed to Asus, but I have seen the error of my ways

Recommended Posts

I was one of those Asus P5N-T Deluxe owners. Not that the board ever worked or anything. I mean, it's Asus, it's just supposed to work. I am not getting an RMA because the store I bought it from isn't selling them anymore! So I am now looking for a new MB. I have the Intel Q6600 already so I'm locked into that part. I also have 2xMSI 8800GT 512MB so SLI is a must. I expect to have to send back the memory, but that shouldn't be too big of a problem.

 

What do the great readers of this forum, who are always right, suggest? My old DFI hasn't been problem free, but after a post or two here, it's been rock solid.

 

Thank you for your help, as always.

Share this post


Link to post
Share on other sites
Guest Retratserif

I could say that was a bit skeptical at first when I purchased my Expert Motherboard. It was one of the most expensive boards at the time too.

 

It was to good to be true with all of the options. The first one died, though Rgone helped me through the RMA process. Once I got my replacement, it was rock solid. I have only crashed it when hitting frequencies out of my Rams's range or going over 2.85 with my 3700+. It was not the greatest OC'ing chip.

 

I would have to say DFI made the best 939 motherboards of all time. Highest Stability and Overclockability.

 

 

If you are going for SLI, get a 780i or 790i if you have extra for DDR3. You could even get a 680i, though the Quad Core OC'ing is not the greatest. Loads of guides and tweaks you can do to "Maybe" help reach higher OC's, but its always a gamble there.

 

I am still waiting for my XFX 680i to return. It worked great until I went to install it in my Case. Not sure why it died. I could not find any grounded areas or anything. They should be shipping it soon. If not, I will contact them and ask for compensation. Its been 3 weeks since it was determined dead and not my fault. I may get lucky and get a 780i. They know I have DDR2 and a E6750.

 

I wanted a good SLI mobo, and was thinking of DFI, so came here to see if anyone had good experiences. Somehow, I found that Praz had an 680i that was unmolested and purchased it from him. Once I get it back, we will see how good XFX mobo's are.

Share this post


Link to post
Share on other sites

Might want to hold off on a 790i based board until the dust settles. More then a few users have and are experiencing hard drive corruption issues.

 

@Retratserif

Might want to give XFX a call and see what's taking so long.

Share this post


Link to post
Share on other sites

DDR3 is a bit pricey. I don't really want to go 790i. What 780i options are out there for DDR2 and SLI? If SLI wasn't in the game I'd do an Intel chipset, but I'm already committed to SLI.

Share this post


Link to post
Share on other sites

Asus motherboards have always been good boards, what is the problem with yours?

before you decide to ditch it, have you made sure you installed everything correctly and you didn't skip anything?

Share this post


Link to post
Share on other sites

Yeah, it's broke. It just stops at the BIOS screen showing the Asus AI logo and "Hit DEL to go to BIOS". Swapped everything with known good parts but the CPU. BTW if you check newegg.com, they don't sell it anymore... Was there yesterday, but not today...

 

No BIOS beep codes, or anything. It's done the same thing every time. Gets to that screen and locks. Once in a while, I can hit TAB and see that it correctly sees the amount of RAM that I have in it, and the Core 2 Quad 2.4Ghz Q6600, but that's all it does.

 

Looking around the web, [H]ardOCP says it sucks, and so does everyone else I've seen. So, I'm going to wave goodbye to it. I've used more Asus boards than I can count, but their quality is definitely going downhill over the past few years. So it'll probably either be a MSI, XFX, or eVGA, as those are the big boards I see around currently with 780i chipsets.

Share this post


Link to post
Share on other sites

haha well ok, if hardcop says so.:rolleyes:

You can contact newegg and they should be willing to refund your money on an item they no longer sell as long as the one year since you purchased it hasn't elapsed.

Good luck.

Share this post


Link to post
Share on other sites

The New eVGA 750i FTW might be a winner. Posted 500 fsb on evga forums and is in hands of reviewers on xs soon.

 

Link

 

 

Item#:N82E16813188026 Please use the newegg link on the top of the page if possible!

 

$189.99

3 Business Day Shipping $8.55

(Not available in HI, AK and PR)

Share this post


Link to post
Share on other sites
Guest SuppA-SnipA
. You could even get a 680i, though the Quad Core OC'ing is not the greatest. Loads of guides and tweaks you can do to "Maybe" help reach higher OC's, but its always a gamble there.

 

is that for quad cores in general or the 680i chipset only?

Share this post


Link to post
Share on other sites

Been a long time since I had used anything but a DFI mobo.

I'd had a terrible experience with ASUS many years ago (2001 maybe?).

It may have been my utter n00bness at the time (as opposed to my current n00bness):).

 

I really felt I had been left out to dry as my e-mails (and I e-mailed every department I could find) either went unanswered or took 3 weeks for a reply.

I swore I would never buy another ASUS product and looked with utter disdain at any rig with an ASUS component it.

Hated them more than Intel :D

I guess the word would be "anti-fanboi".

Never shy about sharing the horrible experience I had.

 

About 14 months ago I purchased an ASUS laptop (like $1200 - a lot more than a motherboard) and it's been very dependable and hassle free.

I ran across a deal I couldn't pass up on an ASUS Maximus Extreme open box.

So I ordered it and the lowest price DDR3 1333 I could find (Corsair Twin3x2048-1333C9dgh) and pulled the E8400 out of my DFI LT LP P35 with Mushkin DDR2 (D9s) and turned it on.

No issues, no problems, running at 4050MHz and passing OCCT tests in about an hour and 2 minutes :)

C1E and all the "features" enabled. It was easy weezy.

 

http://premium1.uploadit.org/soundx98//Maximus-4050.JPG

 

http://premium1.uploadit.org/soundx98//Maximus-OCDB.JPG

 

Do I like the ASUS rig?

YES

 

But I like my DFI P35 more. Even though Benchmarks are almost identical.

Using Praz's Vcore on Auto and adjusting just VID Special % settings I find it snappy with a kewl bios and I love the looks.

I'm extremely Angry about some of the business decisions that DFI has made.

But the NF2s, NF4s,and P35 have been excellent performers for me.

I know that is not true about other products they have made (NF3 Ultra-D fiasco anyone?)

 

http://premium1.uploadit.org/soundx98//48-hr-Prime-3D01.JPG

 

http://premium1.uploadit.org/soundx98//Benchmark.JPG

 

Some guys like blondes, some like redheads, some like brunettes but we all like em nekid.

 

(I can use both rigs at 4200 without issue but Core #0 on the CPU fails Prime.

If I spun you around three times and have you use and bench the rigs you'd have a real tough time determining which was which.)

 

Obviously I needed another C2D.

I am very, very happy with the E8400 (my 1st Intel product ever, temp readings are a nightmare, but man do they OC well).

But this time I went with a Xeon E3110 server version.

 

Helped a co-worker assemble a Gigabyte P35 rig and it went smooth as hale.

Just easy to use and a great value as so many of the mods here have pointed out.

An incredible value.

Personally I think the mobo is butt ugly.

Way too many colors clashing for me. Especially the nekid board.

 

Oh yeah, I'm off my "Corsair is evil" kick as well.

Not sure why I disliked Corsair products sooo much.

I'm sure there was a good reason, or maybe I got their name confused with someone else.

The Corsair HX-620 PSU and the DDR3 RAM are incredibly good values, good looking and have excellent support as well.

 

One last turn around I've had.

Some of the early Ultra PSUs got blasted in most forums and were pretty much known as "rig eaters".

I used an Ultra X-Pro 600w in the co-workers build and it was awesome.

Especially considering what I paid for it.

In fact I just bought two more.

 

What I am trying to illustrate is that there are a LOT of great products out there no matter what you hear about particular brands.

Pretty hard to stay in business these days making shoddy products.

Our rigs contain various components that must work together.

Substitute a crap product in the rig and you have a pile of junk.

And if you want to try to increase max performance of the system you better know what the hale you are doing, cause sometimes one setting makes the difference between "awesome" and "horsesheet".

 

I still hate Maxtor.

I know they are just rebadged Seagates these days but I still hate them.

I've even heard that their board of directors opens there eggs on the wrong end.

Unthinkable, just unthinkable.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...