Jump to content
Sign in to follow this  
robbay111

NTLDR is missing.... :(

Recommended Posts

It figures that last week I had a problem connecting to the internet which took me 2 nights to resolve, and now I have yet another problem that is or was caused by updating a driver. (Which really serves me right since I HATE messing around with drivers because they always seem to EFF up my system :() PLUS it figures that right after I order a processor upgrade & a heatsink upgrade I pull some bonehead move and mess around AGAIN with a effin' driver BAHH!! Talk about some bad karma!!!

 

I can't even recall which driver I was updating but It restarted and now I can't get back into windows. I've Google'd as much as I possibly can, I can't read through the random threads that are all over the place anymore.

 

The fixes that I have tried....

I've changed the boot priority from my HD to my CD-ROM and tried booting up with the Windows XP CD in the drive to enter the 'repair mode'

 

I've tried making a boot disk and booting from the removable floppy to no avail

 

I've tried "copying the NTLDR file & the ntdetect.com files from the XP CD but I'm being told that I Have no access. *not sure why*

 

I've also tried the cmd in the repair mode "bootcfg /rebuild" but i get this error message

""failed to successfully scan disks for Windows installations. This error ma be caused by a corrupt file system, which would prevent bootcfg from successfully scanning. Use chkdsk to -- detect any disk errors.""

 

So I "chkdsk /p" to check the volume and "chkdsk /r" which also seems alright.

 

I haven't tried the """ expand d:i386hal.dl_ c:windowssystem32 """

Since I've also seen that it may add to your list of problems...

 

And not to mention I've tried the bcupdate2 fix as well. *lol i know..*

 

I do have TWO drives, but my main & C: drive is my western digital which is the drive w/ windows installed. **I'm not sure what bois settings they are running at right now** But from what I've read thus far on the issue, it seems as if there is a corrupt file somewhere on the drive which is causing it to perform as a 'non bootable device' or something along those lines.

 

I'm kind of leaning towards just taking my computer in, and having them try to tinker with it to get it going.

If I ask the shop to just grab an extra HD that has XP Home loaded on it, then boot up the computer and try to fix it that way.... Would that work?

or am I off base with that?

 

Ps: I'm very sorry it's a long post, but I would REALLY appreciate any help/direction that may help me in this manner.

Share this post


Link to post
Share on other sites

Sounds to me like the HDD has bit the dust. I'd recommend buying a new drive and loading the OS on it; you may then be able to access the data on the existing drive to recover your files.

Share this post


Link to post
Share on other sites

really eh?

 

seems weird that just outta nowhere it would cack like that.

 

but I'm sure that's definitely a possibility.

I suppose it's a good thing then that I'm waiting for a 500gb MyBook to arrive off backorder then

 

edit:

If i'm able to somehow get back into my system and complete a system restore....

what should i do to ensure that 1. my drive is alright, and 2. a solution that could possibly prevent something like this from happening again?

Share this post


Link to post
Share on other sites

Don't be discouraged. This is the only way to learn. Hey, stuff happens.

 

Make sure you don't have a floppy disk in a floppy drive.

 

It is not seeing a bootable drive. There are 2 settings in your bios.

 

1. One setting is for the boot order, CD, HD, etc.

2. The other setting is for boot preference. I am not near a genie bios and can't remember if this is only active if you are running raid0. Both my Genie bios have raid active.

 

Short story is find the "boot preference" option and make sure it is set the HD. It may have changed when you updated whatever driver.

 

If this does not work then try this: (assumes you can find your was around the command line environment)

 

Windows XP users

 

1. Insert the Windows XP bootable CD into the computer.

2. When prompted to press any key to boot from the CD, press any key.

3. Once in the Windows XP setup menu press the "R" key to repair Windows.

4. Log into your Windows installation by pressing the "1" key and pressing enter.

5. You will then be prompted for your administrator password, enter that password.

6. Copy the below two files to the root directory of the primary hard disk. In the below example we are copying these files from the CD-ROM drive letter "E". This letter may be different on your computer.

 

copy e:i386ntldr c:

copy e:i386ntdetect.com c:

(e is your cd drive)

 

7. Once both of these files have been successfully copied, remove the CD from the computer and reboot.

Share this post


Link to post
Share on other sites

alright

 

I just got home from work, wasn't able to take the system in since I had little access to a car today, and I'm not sure what I did differently but I re did exactly what Smyth posted (even though I'm 98% sure I did these steps before) but I tried them again.

 

Re-booted from the hard-drive, was able to at least pop into safemode... did a system restore and it seeeems to be working now.

 

(Why is it that after hours or searching and then FINALLY submitting your problem to a forum or whatever................. that your system always out of the blue recovers and appears to be working....?)

 

I'll leave SP2004 running to check a few things...

 

however, now that I was able to actually get back into my system, is there anything I should run? like a drive diagnostic (besides de-frag) or something along those lines...

Share this post


Link to post
Share on other sites

I'm guessing your boot priority was changed or the setting didn't take for some reason.

 

It is always scary to think the HD may be gettin' cranky but NTLDR is a familiar greeting when changing things in the system. At least it seems to like me for some reason.

 

You could run scandisk. Spinrite is the ultimate but paying for it is painful. I hate to say you are probably OK (being wrong is never fun) but you are probably OK.

Share this post


Link to post
Share on other sites

I was having the same problem last night when installing fresh windows XP. Quess what helped for me? I have two drives and when disconnecting the other one the one without operation system everything worked fine!!! :confused:

 

Seems that something goes wrong in the system when installing operation system, not so often but sometimes...

 

I think that windows setup copies some setupfiles on the other disc and if u want to boot from the one with operation system, system (bios?) gets confused...so do I :tooth:

Share this post


Link to post
Share on other sites
I think that windows setup copies some setupfiles on the other disc and if u want to boot from the one with operation system, system (bios?) gets confused...so do I :tooth:

 

Windows copying files to second disk = NO

System gets confused = Yes

 

Even if you have set the BIOS perfectly and told it what the boot disk is, BIOS still has to deal with IDE and SATA. Especially on "older" (time flies) boards the IDE SATA thing is not perfect and does not behave as well as we would like. Individual drives, brands, types have an impact on this also. So when you removed the IDE and gave SATA as the only option, all conflicts were gone. The BIOS instructions are not very complex (it is the Basic input/output system after all) so the simpler things are the better luck you have. Later when Windows is installed and you have a more complex and sophisticated set of drivers to handle all this IDE/SATA stuff life usually is easier. All IDE is usually no problem. Mixing IDE/SATA can take a little dinging around. Even using all SATA can take a little work at times. Maybe this is all worked out on new boards. I'm always a year or two behind.

 

This is my gorilla tech view, knowing nothing about it what so ever.:)

 

You were wise to remove the second drive while installing and setting up. Good work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×