Jump to content
Sign in to follow this  
puzzled

Swiftech H20-220 APEX ULTRA versus CoolIt Freezone

Recommended Posts

The pump started to leak between where the 2 halves join after a few days of use. I thought there wasn't enough coolant in the lines when I started out, but it seemed to work fine. Core temps weren't as good as some others had stated, but they were better than the Vigor Monsoon II. It took a few days, but I noticed Core Temp was giving me readings about 10 degrees higher than normal. I left the side panel off so I could monitor for coolant leakage. There had been none after 2 days of prolonged usage. I looked inside the case & saw a pool of coolant. I powered down & unplugged the system. I need to contact them for a RMA.

 

That's rough man; Hope they take care of it for you.

Share this post


Link to post
Share on other sites

I've got a 2nd Freezone on another system & it works great. Keeps core temps much lower than any air cooled HSF has ever done for me, even when over-volting the CPU substantially.

Share this post


Link to post
Share on other sites
What do you mean "whats my setup"?

 

My mistake. I was staring right at it. I have the X2 3800+ running @ 2.75GHz with 1.5v. I really haven't tried to push it very hard yet. HSF is an old Zalman CNPS7000-AlCu from back in the day. P180B case with the 3 factory fans on low. OCZ PC4800 DDR. I have no idea what the core temps are because it's a Linux box

made from what ever spare parts I had left over from days past.

Share this post


Link to post
Share on other sites

That's all the MB will give me anyway. It's an Asus A8N-SLI. The Freezone allows you to punish the CPU voltage-wise to find your peak speed. I have pushed close to 1.8v through an Opteron 165 just to find out if my peak was held back by not enough voltage. The core temps never got above 40c. That was on an Asus A8N 32-SLI. BTW, anything above 1.65v showed no improvement.

Share this post


Link to post
Share on other sites

I was finally able to ship it yesterday. :( I keep some weird hours, so I'm not able to get things done as fast as I'd like sometimes. I kept the package ready to ship in my trunk until I was able to get it to a UPS Store during business hours. The 1st two attempts I missed by a few minutes. On the 3rd shot I made it with 10 minutes to spare. It's finally on its way to Calgary. Shipping was $50. I don't know on what scale this registers as a hassle for me or not. I have 2 of these units, 1 that's worked fine from day 1, & the other that has cost time, money, & customs paperwork to ship back. It would be easier if a call tag could be issued.

.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...