Jump to content
Sign in to follow this  
Timber Jockey

XFI Sound Card Problem

Recommended Posts

When I try and run BF2 Sound on Ultra High with Hardware rendering after a out 20min's of playing All I get is & a lot of sataic. I'm using a Creative Labs XFI Fatality Pro Series Sound Card. Latest drivers ( only drivers ). So what could be the problem ??

Share this post


Link to post
Share on other sites

How are all your other games running with sound? If this game is the only one that has issues with your sound card than look into some patches directly for this game unless you've done that already. Did you look into the Single Core procedure in order to run the game properly? This is all i know....

Share this post


Link to post
Share on other sites

Thx Mack27 :cool:

 

Ya it is the only game that does it & it only does it when I set BF2's sound to ultra High. I have the latest patch for the game ( 1.41 ) & the latest drivers for my sound card which is the one that comes with the cd. So I guess I'll have to leave the sound set to high.

Share this post


Link to post
Share on other sites

Mine does the same thing. It works great in every game but when I set it to Ultra High in BF2 it works great for about 1 to 2hrs and then messes up. Hopefully they put out some drivers to fix this problem.

Share this post


Link to post
Share on other sites

How is the air flow around your card? It could be getting a bit hot in Ultra-High mode due to off-loading processes from the CPU. I have the same card and I run it on Ultra-High in BF2 but I have an open PC case so I've never experienced the static you speak of.

Share this post


Link to post
Share on other sites
Thx Mack27 :cool:

 

Ya it is the only game that does it & it only does it when I set BF2's sound to ultra High. I have the latest patch for the game ( 1.41 ) & the latest drivers for my sound card which is the one that comes with the cd. So I guess I'll have to leave the sound set to high.

 

The latest drivers would be the ones from their website....

Share this post


Link to post
Share on other sites
The latest drivers would be the ones from their website....

 

Sorry for bumping this thread back to the top, but I saw this comment and was thinking... "Ya, you'd think so." However, when you go to the creative website there are no drivers to download for the X-fi Xtremegamer sound card. So, it would appear that the CD that comes in the box actually DOES have the latest drivers. Which is ridiculous!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...