Jump to content

x-fi Sound Card Optimizing performance


Recommended Posts

I'm trying to get some advice how to get the most from my X-Fi Fatal1ty sound card from Creative.


I love the remote and all it's features and CMSS 3D Settings, but I really want to get rid of the "white noise" that i've always had with sound cards, It could be just my headphones that make this white noise, but I want to reduce it or remove it, the best way so far is to lower my master volume to about 40% and it's not annoying.


I have K-Lite Codec Pack, and updated drivers.

I've never updated my bios, or worked in any advanced settings.


I'm going to relocate my sound card to another PCI-Slot (The bottom one, farthest away from all my components) to see if I get better performance.


Here is a link that creative support gave me to work with my sound card,




Hope that helps anyone with X-Fi sound cards.

Share this post

Link to post
Share on other sites

Hmm I don't have white noise even at max volume through my headphones but I do get white noise when I turn on my Z-680 speakers. Did you check with pair of headphones to confirm its the soundcard? I wish Creative has better support with the remote, so far I've found it useless since remapping it for windows apps takes to long and 3rd party programs either is shareware or well it doesn't detect my remote for some reason.


The only thing I've done when I installed my X-Fi was to disable the onboard sound in the bios and made sure it was on its own IRQ, no problems since then.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...