Jump to content
Sign in to follow this  
passionne

[RESOLVED]REMOVE ATI TOOL>> FPS inaccurate KB responses

Recommended Posts

Hello,

 

When I play first person shooters (Far Cry, Doom 3, FEAR, Splinter Cell Chaos Theory, Max Payne 2...), the following phenomenon occurs : when I stop pressing a movement key (W, S, A or D), sometimes, the character keeps on going in the direction during a few seconds : for instance, when I press W, the character goes forward then when I stop pressing this key, it goes forward a few seconds before stopping. It is quite annoying.

 

What I did to solve this problem :

- changed the wired PS/2 keyboard (Logitech) by another one.

- changed the PS/2 wired keyboard by another one via USB.

- flashed the motherboard bios (0704-2 beta, 0510-3)

- in Notepad, I pressed the W, S, A, D keys to see if the same phenomenon encountered in the games, occurs. No : when I stop pressing one of these keys, it immediately stops being pressed on the screen.

- changed the Nvidia driver (6.66 to 6.86).

- I did not reinstall Windows XP SP2 but I installed Windows XP 64 bits and Far Cry x64 and I have the same problem : so, it does not seem a OS-related problem.

 

In non-FPS games (simulations, RPG, RTS), I don't encounter this problem.

 

Any idea ? Indeed, I wonder if the cause could be a hardware failure.

 

Thanks for your feedback.

Share this post


Link to post
Share on other sites

Hi.

 

My friend has the same problem, which is quite confusing as i built his rig almost identical to mine, an i don't have the problem.

Going to follow this one close, as we yet haven't found a solution.

 

/T

Share this post


Link to post
Share on other sites

Thanks for your feedback.

 

I fear that it is a hardware-related problem. But if you find a solution, may you report it in this thread, please ?

 

Thanks.

Share this post


Link to post
Share on other sites

I read somewhere that the VSync and frame buffering can cause this effect because the GFX card has multiple frames drawn by the time you let go of the key.

 

Try turning VSync on.

Share this post


Link to post
Share on other sites

Maybe a dumb question but you do have DirectX 9c installed?

 

With the USB KB you could try enableing USB keyboard support in the BIOS (although this should not have affected the PS2 keyboard.)

 

When you Flashed the Bios did you follow the DFI guide and clear the CMOS and load optimized defaults? (you'll need to search for the CMOS Clear guide)

 

Does it continue to move forward in Farcry if you just tap the W key or only if you hold it down for a time and then release?

 

I would try putting all the GFX settings to their lowest possible settings including resolution and see if it is a lag in the display or the keyboard input.

Share this post


Link to post
Share on other sites

Maybe a dumb question but you do have DirectX 9c installed?

 

Yes, DirectX 9.0c is already installed.

 

With the USB KB you could try enableing USB keyboard support in the BIOS (although this should not have affected the PS2 keyboard.)

 

No effect.

 

When you Flashed the Bios did you follow the DFI guide and clear the CMOS and load optimized defaults? (you'll need to search for the CMOS Clear guide)

 

I don't remember but I cleared CMOS yesterday in order to be sure, by following the Clear CMOS guide. No effect.

 

Does it continue to move forward in Farcry if you just tap the W key or only if you hold it down for a time and then release?

 

Yes, the problem occurs in both the cases : if I tap or hold it down the movement keys, the problem sometimes appears.

 

I would try putting all the GFX settings to their lowest possible settings including resolution and see if it is a lag in the display or the keyboard input.

 

No effect by lowering the display resolution.

Share this post


Link to post
Share on other sites

Recap:

1..The keys are not sticky in notepad.

2..Game settings and resolution do not affect it

3..RTS games are not affected

4..CMOS Cleared and reset

5..Same effects on USB and PS2 Keyboards

6..Bios Flashed

7..Windows 32 and 64 show same effect with farcry64

8..More than one game shows the effect.

 

Assumptions:

a..The hardware is ok or you would be seeing the sticky keys in all programs.

b..The keyboard buffering or polling mechanism used in games is storing key presses beyond the visual cue to release it.

c..The Video system is buffering frames beyond the key release signal.

 

I am just about out of ideas I am afraid.

 

All the games are directX?

 

Do you have any openGL based games? (thinks: maybe a problem with directX)

 

Have you tried the ATI demos they have keyboard control as well in some sections.

Share this post


Link to post
Share on other sites

I followed your advice : I tried Open GL games, in particular Doom III and Chronicles of Riddick.

 

On Doom III, there was not any problem. And on Chronicles of Riddick, I encountered stutter, probably caused by Catalyst driver.

 

Before changing the Catalyst release, I removed ATI Tool from my computer, the overclocking utility for ATI cards.

 

I tested Half Life 2, Splinter Cell Chaos Theory (not Far Cry because of a Catalyst problem on Windows x64) and the problem does not appear at all whereas these 2 games were affected before.

 

I will go on testing with other FPS, in particular Far Cry, when I will have reinstalled Windows x64. And I will confirm in this thread if it was the cause.

 

Thanks for your help.

Share this post


Link to post
Share on other sites

When you install Catalyst drivers did you use Driver Cleaner in safe mode to make sure it was really all gone? Just wondering...

Share this post


Link to post
Share on other sites

No, I did not use Driver Cleaner.

 

I must reinstall Windows x64 because of a bug caused by Catalyst : I removed the 6.11 release (Delete programs) but I cannot reinstall the driver any longer.

 

But if I use Driver Cleaner in Safe Mode in order to remove all the remaining Catalyst components, how to do : my PC has dual-boot, Windows x64 and Windows XP SP2 : how to choose safe mode in Windows x64 only ?

Share this post


Link to post
Share on other sites
But if I use Driver Cleaner in Safe Mode in order to remove all the remaining Catalyst components, how to do : my PC has dual-boot, Windows x64 and Windows XP SP2 : how to choose safe mode in Windows x64 only ?

 

When you press f8 during startup, choose safe mode. Then it will display a list of you're OS(s) and you will be able to directly choose which operating system you want loaded.

 

Good luck!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...