Jump to content
Sign in to follow this  
General Septem

Testing connector with DMM

Recommended Posts

Yes I did search, and I found a link to a site that shows how to use the DMM to test voltage rails, but my question is somewhat different.

 

See I think one or both of the PCIe connectors from the PSU is faulty. I just fried two video cards (one of them caught fire) and I'm thinking it might be the PSU.

 

So when I test the connector, what exactly should I check for and how should I check for it?

 

Another somewhat related question, are both PCIe connectors on the OCZ PowerStream 520w on their own rail, or do they share a rail with other connectors? Because if there's an overvolt on the rail going to the PCIe connectors, it's odd that none of my other components are affected.

Share this post


Link to post
Share on other sites

I don't mean to be impatient, but can someone please answer my question before I send this back for a refund? Because if it's the PSU I'll request an RMA replacement rather than lose a $50 restocking fee for a refund. Any help at all would be very appreciated.

Share this post


Link to post
Share on other sites

Never actually done it, I just remember reading about it.

 

Put the black lead from the DMM into the black ground of the connector, and stick the red one in on of the yellow ports on the connector. Start up your system and put some heavy load on it. Check to see the voltage fluctuations and how close it stays to 12v. I think +/-5% is allowed.

 

Im sure google or some other web forums have more info.

Share this post


Link to post
Share on other sites
Never actually done it, I just remember reading about it.

 

Put the black lead from the DMM into the black ground of the connector, and stick the red one in on of the yellow ports on the connector. Start up your system and put some heavy load on it. Check to see the voltage fluctuations and how close it stays to 12v. I think +/-5% is allowed.

 

Im sure google or some other web forums have more info.

 

That's the site I saw, but I'm just wondering if the connector's shorted out or something if the procedure for checking that is different. Also how would I check for amps?

Share this post


Link to post
Share on other sites
Guest erico

You don't have the capability to check it for amps easily. You check for amps using the Amp setting on the DMM and it is done in series with a load, not parallel. The amp setting must be a larger setting than the amount of amps you wish to check. The meter leads are also connected to the meter in a different postion than you have used before.When checking for volts the DMM is connected in parallel.(red to (+) and black to (-) ) . It is the opposite when checking for amps. Unless you are a tech and have done it before think twice before even considering trying it. It takes only .03 amps or 30 milliamps to kill you and you probably want to make it to your next birthday!!

 

Your question about this means you are not a technician or Engineer. That is neither a good or bad thing. Stay safe!!

Share this post


Link to post
Share on other sites
You don't have the capability to check it for amps easily. You check for amps using the Amp setting on the DMM and it is done in series with a load, not parallel. The amp setting must be a larger setting than the amount of amps you wish to check. The meter leads are also connected to the meter in a different postion than you have used before.When checking for volts the DMM is connected in parallel.(red to (+) and black to (-) ) . It is the opposite when checking for amps. Unless you are a tech and have done it before think twice before even considering trying it. It takes only .03 amps or 30 milliamps to kill you and you probably want to make it to your next birthday!!

 

Your question about this means you are not a technician or Engineer. That is neither a good or bad thing. Stay safe!!

 

Haha, fair enough. If it doesn't kill me it would probably turn me into some kind of science fiction monster. :tooth:

 

So if the connector is causing problems with the video card then, what should I check for?

Share this post


Link to post
Share on other sites
Guest erico
Yes I did search, and I found a link to a site that shows how to use the DMM to test voltage rails, but my question is somewhat different.

 

See I think one or both of the PCIe connectors from the PSU is faulty. I just fried two video cards (one of them caught fire) and I'm thinking it might be the PSU.

 

So when I test the connector, what exactly should I check for and how should I check for it?

 

Another somewhat related question, are both PCIe connectors on the OCZ PowerStream 520w on their own rail, or do they share a rail with other connectors? Because if there's an overvolt on the rail going to the PCIe connectors, it's odd that none of my other components are affected.

PCI-eXpress.gif

I will edit this and answer the other questions later, unless someone else pitches in.:) Check the connectors with a DMM. They should each be 12vdc. Don't forget to load the PSU with a spare HDD/ODD/FDD or two.

 

What part # is your OCZ PowerStream 520w?

Share this post


Link to post
Share on other sites
PCI-eXpress.gif

I will edit this and answer the other questions later, unless someone else pitches in.:) Check the connectors with a DMM. They should each be 12vdc. Don't forget to load the PSU with a spare HDD/ODD/FDD or two.

 

What part # is your OCZ PowerStream 520w?

 

OCZ-520ADJ SLI, is that what you were looking for?

 

The clip is supposed to be on the +12v side? On mine the clip is on the ground side. Could that be causing the problem? (well obviously it's a problem if it's supposed to be the other way around, but I'm just making sure)

Share this post


Link to post
Share on other sites
Guest erico
OCZ-520ADJ SLI, is that what you were looking for?

 

The clip is supposed to be on the +12v side? On mine the clip is on the ground side. Could that be causing the problem? (well obviously it's a problem if it's supposed to be the other way around, but I'm just making sure)

When you put your red meter lead to the +12V(Yellow) and black meter lead to the GND(black) on the opposing side is the diagram accurate?

Have you tested all three pairs in the connector?

If they are indeed connected backwards, inadvertently during assembly at the plant...what has happened to your GFX card really makes sense.

Share this post


Link to post
Share on other sites
When you put your red meter lead to the +12V(Yellow) and black meter lead to the GND(black) on the opposing side is the diagram accurate?

Have you tested all three pairs in the connector?

 

I haven't put a DMM up to it yet, but the yellow wires are going to the wrong side of the plug. Should I tet it with the DMM to make sure this is actually the case? Also, should I turn the computer off first and jumper the ATX plug, or should I leave the system on?

Share this post


Link to post
Share on other sites
Guest erico
I haven't put a DMM up to it yet, but the yellow wires are going to the wrong side of the plug. Should I tet it with the DMM to make sure this is actually the case? Also, should I turn the computer off first and jumper the ATX plug, or should I leave the system on?

Take a look at this first.

PCI-eXpress.gifPCI-eXpress_PWR.gif

I corrected the bad diagram.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...