Jump to content
Sign in to follow this  

nVidia IDE SW driver update!

Recommended Posts

Thanks Ex Roadie. I was still assuming these drivers were crap and so i tried to install as less as possible.

(edit)There seems to be a problem though. I just installed them drivers, and after that i ran hdtach and where the numbers used to be around 180 (between SATA 150 and SCSI ultra 320) it now dropped to a staggering 95.3MB/s (lower than ATA figures). How the f00k is that possible, its almost a 50% cut in burst performance.

Anyone any clues? (edit)I need some sleep. I was checking the wrong disk ffs, my PATA wd 200g disk, so even if the numbers seem a bit low to me, it's more logical.

And btw it's great to see that now non DFI users can add knowledge or use the knowledge from this great forum too.

Regards Beernut

Share this post

Link to post
Share on other sites

Good thread, was looking for an excuse to try the NV drivers.


Based on a couple of tests (boot time, HD Tach), here's my results (switching from MSFT drivers to NV):


* Boot time decreased 7.5% to 80 seconds (from 86)

* CPU utilization increased 57% to 3.66% (from 2.33)

* All other HD Tach stats showed no difference


I tested both boot time and HD Tach 3 times and averaged them. So not a big sample by any stretch.


Despite the CPU utilization increase (which I find suspect with such a small sample), I'll probably stick with the NV drivers unless a problem starts cropping up.


My reasoning:


* System feels a bit snappier (totally subjective, I know)

* I like faster boots (even if it is only 6 seconds)

* I can turn command queuing off on my Raptor 150. I've seen some results suggesting that turning it off in a non-server environment (me) results in increased performance and less potential problems with the NV drivers. The MSFT drivers don't give an option to turn NCQ off.


That's it, cheers.

Share this post

Link to post
Share on other sites
Guest hengehog

I keep getting option rom messages upon boot (Vendor ID) messages & have not managed to install the nVidia SW driver without having to completely re-install OS. I'm running XP64 on Raid 0.

Does anyone know if there has been an update to the XP64 drivers?

I heard that you can safely install some of the NF4 drivers, but as I've only just got myself a new CPU, am just getting back into sorting all the O/C's out again.

Any help greatly appreciated,



Share this post

Link to post
Share on other sites

i'm planning to re-install windows with nVidia IDE SW driver, but what about nvidia firewall does it still have issues?

Share this post

Link to post
Share on other sites

Lastest NF4 IDE running without any problem. In fact, I always move the file around and verify it using MD5 hash. So far the all passed the hash check.

Share this post

Link to post
Share on other sites

Well, everyone seems to be posting positive results with the newest drivers, but I had a MAJOR problem. My Boot drive was corrupted and I could not fix the problem no matter what I tried.


I downloaded and installed this file:


from the nvidia web site.


I selected:

-Platform / nForce Drivers

--nForce Series AMD

---Windows XP / 2000


(This was the correct file for my Motherboard, right?)


And installed both the SATA drivers and the IDE drivers. I think it was called legacy IDE drivers.


Just FYI, ALL my Hard drives (I have 3) are SATA and they are NOT in any RAID configuration.


I first did my own test, I Ripped a DVD to a hard drive. BEFORE loading the drivers, the rip took 9.29 minutes.


After loading the drivers, and doing a re-boot, the same rip took 9.15 seconds, or 14 seconds faster.


While I will take any speed increase that I can, 14 seconds seemed to me, to be within the margin of error for ripping a DVD. But Still, it was testing both the IDE drivers and the SATA drivers.


So then, I wanted to try a slight modification to my my Overclocking settings, and as I am near the limit, I moved my HTT up one number, or a 10.5 Mhz clock speed increase.


Started Prime95 (Orthos), and after a short while, my system froze, or Orthos enountered an error (I forget which one). Now here is where my details are a little fuzzy, I do not remember if I was able to re-boot and try another overclocking setting again, or my Boot drive was corrupted.


But at any rate, after 1 or 2 different OC's settings (very minor changes), I could not boot into my system, the bios would post, but then just a black screen.


At first, I thought it was a corruped bios, so I cleared the bios via the red jumper, but that didnt help, and then I realised that I could boot to my CD or A drive and I confirmed that was true.


I booted to my XP CD, and the install CD saw that I did have a "C:WINDOWS" directory, so I knew that my data was not lost.


I did the XP Recovery Console, and could access the C drive, so I tried to do a XP Install Recovery option, and as soon as the recovery I got a "crashed XP" message that said something about the "bios ide".


I did not write down the exact error, but it was one of those messages that also say something like "If this is the first time you received this message, try re-booting your PC and try to disable caching".


Anyway, I had a spare SATA drive, so I did a fresh install of XP, SP2 and all is well (after a weekend of re-installing everything!)


Now I did NOT install the AMD optimizer or the XP "dual core" programs, and all is working fine.


I did another test burn of my DVD, and the burn took 9:20, right in the middle of my two previous test burns.


ALSO, I seem to be stable at a slightly higher CPU Speed! The highest I was able to be stable at was 2834 MHz, but as of this morning, I was 7+ hours prime stable at 2857 MHz. I left Prime95 (Orthos) running while I left for work, and am anxious to see if it is running when I get home.


Now to be fair, I did make some minor changes to my memory settings.


I changed the:

DRAM Drive Strength

from 8 to 1 (This was a big change, and might be the primary reason for the new found stability at the higher clock speed)

and the

Max Async Latency

from 8 to 9

and the

Read Preamble Time

from 5.5 to 6.5


So in summary, while I cannot say for sure that the nVidia nForce drivers were the cause of my system crash, the nVidia drivers are my LEADING SUSPECT at this time.


I have been overclocking this system for at least 6 months, and never had an OS problem while experimenting with Overclocking numbers. and I was trying some pretty wild numbers when I first started my OC'ing!


Oh, I guarantee you, that tonight I am making a Ghost image of my C drive. While I had all the software etc to do a re-install, it STILL was no fun re-installing and tweaking and getting all the updates, etc.


Oh, another thing, I WAS able to hook up my corrupted old "C" drive, after I had my "new" Boot drive set up, and I was able to get all my data that was on the C drive, YEA!

Share this post

Link to post
Share on other sites

Does anyone have any experience using the IDE driver with a DFI 250GB nf3?

Thanks for your thoughts and input.



Share this post

Link to post
Share on other sites

Same question here.....always used to avoid these but tightening up the system lately.


I have the OS backedup with Acronis so I plan on installing a new Remix 11? pack tonight; I'll post back here soon.


BTW - do you have any problems with a nic related BSOD? If I try to do anything manually with my current network connection I can trigger a BSOD.


The newest Remix driver pack mentions a fix (for XP not x64) for a nic throughput BSOD.





Uninstall your current Ethernet Drivers COMPLETELY, before installing the nforce 3/4 ethernet drivers in this pack."


I think I'll BSOD if I try to do this but I'll give it a whirl.



Share this post

Link to post
Share on other sites
The "safely remove hardware" icon is part of the OS once it is available through the driver.


The driver doesn't "add" the icon. The OS detects the feature in the driver and offers it.


You would have to alter the OS to get rid of the icon but then you would lose that function for all removable devices like USB memory sticks and other Hot Plug items.


It's rather late, but I found the solution to this problem at a different website, which I've tried and works rather nicely. Plus the "Safely Remove Hardware" icon still pops up when I plug in my other removable hardware, it just ignores my main disk.


I'm not sure if linking is allowed, so here's the solution and the link to give credit where credit is due :)




For nForce chipsets, you can add the following to registry:


In HKEY_LOCAL_MACHINE SYSTEM CurrentControlSet Services nvata,


add DWORD DisableRemovable, set to 1. Reboot.


64-bit systems use nvata64. Some chipsets might use nvatabus instead.


This doesn't work with VIA chipsets (driver vide or videX64), the only option I've found for them is to use older drivers that don't support SATA hotplug.

Share this post

Link to post
Share on other sites

I just installed the latest drivers from nVidia and it corrupted my partition. Fortunately I could boot into the Vista repair utility using some older raid drivers from a floppy. All is fixed now but next time I'll check for feedback before I install.


This is the correct driver pack to install right? I can't find anything more relevant in the category selection.


nForce4/500 Series AMD - Windows Vista 64-Bit

Version: 15.00

Release Date: February 5, 2007

WHQL Certified


Release Notes:


* WHQL driver package for nForce4/500 Series AMD motherboards.


Driver Versions


* Ethernet Driver (v65.55) WHQL

* SMBus Driver (v4.60) WHQL

* Installer (v5.40)

* IDE SataRAID Driver (v9.31) WHQL

* IDE SataIDE Driver (v9.31) WHQL

* RAIDTOOL Application (v9.31)

* SMU (v1.23) WHQL

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...