Jump to content
Sign in to follow this  
neilcha

Amd X2 4200+

Recommended Posts

I See On The Inital Build Pics About Plugging Into All Four Power Connectors On M/board . Do I Plug All 4 In When The M/board Is Fully Assembled Inside The Case ??????

Also When I Turned My Pc On Yesterday There Was No Responce.i Took It To My Pc Repair Shop And He Said That The Psu Had Blown ?????.i Only Had The Psu For 3 Days , Hiper Have Said That They Will Replace It With A New One But Why Did It Blow And Will It Happen Again .

Nothing Is Overclocked In My System.

Any Ideas .

Share this post


Link to post
Share on other sites

Hello,

 

Before you power the board you must plug all 4 power connectors into the board.

 

Those 4 connectors must be plugged in at all times.

 

Either the PSU was faulty and it was meant to blow or something caused it to blow, could be anything.

 

Check all your connectors/devices.

Only use what is needed to start the pc, cpu/memory/gfx card.

Leave hard drives/cd drives unplugged.

Share this post


Link to post
Share on other sites

Please quit making multiple post about this. I've already had to delete two of them.

Thank you

Share this post


Link to post
Share on other sites

My Psu Has Blown Could Someone Please Tell Me If My Cpu Amd X2 4200+ Is Not Recomended To Use With My Hiper Type R 580w Psu.

I Have Read The Psu Recomendations List But Where Is Says About It Not To Be Used On Duel Core Systems Does That Mean The List Above Or Below The Statement. .

Share this post


Link to post
Share on other sites

Your PSU should easily be able to power your system - however Hiper have been known to have a few build quality issues in the past. Are you still under warranty period - or are you in the market for a new PSU? I'd personally recommend the FSP FX600/700 which i use on a 24/7 basis, and i've heard that the OCZ GXS are very good.

Share this post


Link to post
Share on other sites

yes my psu is still under warrenty with hiper and they have said that they will replace it with a new one . i only had it for 2 days before it stopped working

Share this post


Link to post
Share on other sites

I Hope So As Well . Ive Been Without My Pc For About 3 Weeks Now ,and Using This Cr___y Dell System Is Starting To Do My Head In .

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...