Jump to content
Sign in to follow this  
bigfaxi

problems with 4gb memory

Recommended Posts

hallo

 

i have a problem with my 4x 1gb ram. the system boots but show me only round about 2,8gb in boot process. the os (linux with 2.6.x kernel) use also only this 2,75gb. Note, the system boots well and run stable!

i test to turn on the bios option "memory mapping" but then the system doesn't boot any more.

Why can i use all of the memory?

(i know that i have to use a 64bit linux to use all the memory. but while the bios is only show 2,75gb it doesn't play any role)

thx for help

 

ben

 

my system:

DFI Lanparty UT nF4 Ultra-D

4x 1gb ram (different manufacturs)

AMD Athlon 64 3500+

MSI RX1650

Share this post


Link to post
Share on other sites

Your RAM need to be a match pairs.

 

Running mixed memory modules is a very difficult thing to do if not impossible. Especially if they are made from a different company and have different chips set on them.

 

 

If you have exact same memory you’ll need to do the following;

 

You will need to disable CPC in BIOS to run four memory modules at 2T.

Genie BIOS settings -- Command Per Clock -- Enable

 

And

 

Enable Memory Hole.

Advance Chipset Features -- Memory Hole for PCI MMIO – Enable

 

Enable Memory Hole remaps memory and allow the system to see up too 4GB. You’re limited to 3.2GB in XP 32bit.

 

 

Test your memory by enabling memtest in the BIOS and test #5 and #8 for 15-20 passes each. Then do all tests for 20 passes. Test the memory in the orange slots. This is to rule out your memory being an issue.

Share this post


Link to post
Share on other sites

I'm using Vista RTM and without PCI MMIO enabled the bios sees 3.4GB and Vista detects 3.4GB.

 

With PCI MMIO enabled, the buis detects 4GB and Vista only detects 3GB.

 

What to do?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...