Jump to content

Urgent! should i upgrade to venus frm ultra D?


Recommended Posts

i am thinking of getting a venus to replace my ultra D which is plagued with problems like boot failures and NB hsf issues.

 

i mean i am not sure if the new board would cause incompatibility issues with my specs below..

 

i am going down later to make my decision so need help guys...

Share this post


Link to post
Share on other sites

No reason to drop the cash for a Venus unless it's a rediculously good price. If you're having problems with your Ultra-D that won't go away why not RMA it?

 

Or at least ask around here for help (if you haven't already).

 

By the way there's no way you could use that Coolermaster PSU on a Venus, so be prepared for some extra cost right there. That could even be the cause of your current boot failures.

Share this post


Link to post
Share on other sites

No reason to drop the cash for a Venus unless it's a rediculously good price. If you're having problems with your Ultra-D that won't go away why not RMA it?

 

Or at least ask around here for help (if you haven't already).

 

By the way there's no way you could use that Coolermaster PSU on a Venus, so be prepared for some extra cost right there. That could even be the cause of your current boot failures.

i have rma-ed it like 4 times already. i heard abt the power supplies list. but why would the CM 550w cause issues>

 

thanks for the prompt replies

Share this post


Link to post
Share on other sites

i have rma-ed it like 4 times already. i heard abt the power supplies list. but why would the CM 550w cause issues>

 

thanks for the prompt replies

What are the chances that you got 5 bad boards? I'll bet you have better odds of hitting the lottery! I'd say it's time to look at another source for your troubles and that PSU is the most likely suspect.

Share this post


Link to post
Share on other sites

I highly doubt the motherboard is the cause of your problems. More than likely like technovandan stated it could be your PSU or your RAM. Value Ram does NOT go well with DFI boards. I also believe there has been cold boot issues with your brand PSU(not totally sure on this though).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...