Jump to content

Problems with Adaptec SCSI cards

Recommended Posts

I'm having a problem in my NF4 Ultra-D motherboard. I tried two different Adaptec SCSI host bus adapters - a 2940UW and a 2920C. The DFI board will not play nice with either board, but I can put either of them in an ancient ECS K7S5A (Barton 2500+) and they both work perfectly.


The Adaptec cards allow you to modify the low-level operations of the board by pressing CTRL-A at some point during the boot. When loaded in my DFI, the 2940 displays the CTRL-A message, but when trying to load, the utility comes back with "There is no SCSI host bus adapter". With the 2920C installed the CTRL-A message never appears and the board will not respond to CTRL-A.


Windows XP loads the correct driver and all appears normal in Device Manager, but trying to poll the SCSI bus on either card causes the DFI machine to immediately reboot.


I'd be interested in knowing if others have working setups with these two older HBAs.


EDIT: I recently installed a Buslogic BT-958, and it has the same problems - cannot access the card's BIOS configuration utility.

Share this post

Link to post
Share on other sites

I've tried the following:

- added an HDD delay in the system BIOS

- moved "Add-in Bootable card" to the top of the boot priority

- reset ESCD

- changed to a 3rd SCSI card

- confirmed that the cards are being initialized at boot-up and have been assigned an IRQ

- mounted a bootable HDD as the only device on the SCSI bus

- changed PCI slots

- loaded DFI BIOS 0406


After all this, the system is still not recognizing/acknowledging the SCSI cards' BIOS at boot time and so I cannot do low-level configuration of the cards.


I'm really stumped. Has anyone seen this sort of thing before?

Share this post

Link to post
Share on other sites

It took a while (a looooong while), but I eventually found what looked like a solution at Adaptec's site. Although the conditions were different and it was for a different product, the suggestions worked. Rather than try to paraphrase and get it wrong, I'll just quote the section that got me fixed.


"This problem can be caused when the motherboard BIOS does not correctly assign the proper resources for the 2200s RAID adapter. The motherboard BIOS is responsible assigning resources (such as IRQ, BIOS memory address, etc.) for 2200s RAID adapter.


By adding 2 GB of RAM to the motherboard, the system would require the change in the BIOS load reserved memory area that normally would take place the next time the system was booted. This does not seem to have take place correctly and must be manually set to force the motherboard to re-allocate the resource for the 2200s RAID adapter and the process for this is as follows.


1. Turn power off on the system and remove the 2200s RAID adapter from the system.


2. Simply insert a bootable floppy disk into the floppy drive and power on the system to boot to the floppy disk multiple times (between 2 and 5 times).


3. Power off the system and put the 2200s RAID adapter into the system and do not connect any cables/drives to the 2200s RAID adapter.


4. Boot to the floppy disk again. This will check the BIOS of the 2200s RAID adapter to make sure it will now show the BIOS banner and search for attached devices and successfully boot to the floppy disk. When the 2200s BIOS is identified on the screen, the motherboard has successfully assigned the resources needed for the adapter to function properly.


5. With the Adaptec BIOS now showing up, power off the system and attach the cable(s) to the 2200s with drives and boot normally as this should now boot to the attached array drives that contains the operating system.


The 2200s SCSI RAID adapter should now function normally as before and no harm to the array drives or data should have take place, but it is a good idea to re-boot the system a few times to test and make sure. Checking the operating system and any data files randomly to make sure the 2200s SCSI RAID adapter is working. "


Several DOS boots off a floppy was all it took for the system to finally hook into the card's BIOS. I doubt I'd have ever thought of this. Hope this is useful info for someone sometime.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...