Jump to content
Sign in to follow this  
douirc

6.86 nF4 AMD Platform Drivers - Performance Issues!!!!

Recommended Posts

Well, I thought it would be a good idea to update my machine with the latest platform drivers from nVidia, but the results have been horrible. As soon as I upgraded my HDD performance went to nill. HD Tach used to produce results around 127, but with the new drivers I'm getting around 18 :(

 

I first thought maybe my drive bit the dust, or the cable came loose or something, but I popped my BartPE CD in and the performance was normal. I even took the time to reformat and install step by step, testing HD Tach along the way. First I installed bare XP Pro and HD Tach performance was fine. Then I installed SP2 and performance was still fine. Then I installed the platform drivers and the performance went down the tubes.

 

I can't seem to find a list of old platform drivers from nVidia's website. Even if I could, I wouldn't know which to download. Anyone have a suggestion on which platform drivers would be best? The most stable? I think the last set I used were from about 6 months ago. Any idea what version nVidia was at 6 months ago?

 

Thanks for all the help!

Share this post


Link to post
Share on other sites

I'm not sure if they will have an older version of the Nforce chipset drivers. But I know www.guru3d.com has a lot of older versions as well as many other versions you have probably never seen before.

 

I hope this helps!

Share this post


Link to post
Share on other sites

Have you tried the drivers that came with your Mobo's CD-ROM ?

Those are usually old...and for me are the ones that work best, specially as far as IDE performance is concerned...

Share this post


Link to post
Share on other sites

you know...

 

I wondered about those...

 

I installed those and I get poor sata performance...I will try those also and see...;)

Thanks...

Share this post


Link to post
Share on other sites
Have you tried the drivers that came with your Mobo's CD-ROM ?

Those are usually old...and for me are the ones that work best, specially as far as IDE performance is concerned...

 

I installed the latest ones from DFI's site and all performance is fine again

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...