Jump to content
Sign in to follow this  
RedDem0n

Error message when booting

Recommended Posts

I hooked my computer up the other day after moving into my new house, and did all the security updates, and antivirus updates to it...restarted and right before I left for work I left it defragmenting my C: harddrive. 9-10 hours later when I come back from work see my computer on but not my normal screen...I see a message saying "Windows could not start because the following file is missing or corrupt: /system32.hal.dll"

 

Now I have no idea how this happened....I did a little research on this and its telling me that my boot.ini might be corrupt and to reload it from the windows xp cd using some kind of bootcfg /rebuild command from the cd itself....so heres the other problem....i cant seem to find my original windows xp cd anywhere....but the good side to this was that i had two other windows xp cd from my other two computers..one from my hp laptop and one from my gateway computer. so i put the hp laptop windows xp home edition sp2 cd in and did what it told me to do....right after i hit i want to go into the recovery console it takes me to the dos screen "Press the number that corresponds to the correct location for the installation of Windows you want to repair, typically this will be #1." ...So here's the thing...the drive that it says windows is installed is under D:Windows when it should be C:Windows..and that was the only one that was listed...so i picked that and did the other two commands to rebuild the bootcfg but it wouldnt work...this is the site i went off of btw http://pcsupport.about.com/od/pcrepair/a/missinghal_dll.htm

 

now the thing is...what im thinking is my computer is not detecting the c:drive...only detecting my 2nd drive?...im not even sure whats going on because my original windows installation is my c:drive and my other drive..which im not even sure if its a label name is d: or some other drive came from my old computer when i just installed in my new one...so what im thinking is that its trying to read off the windows installation on my 2nd drive...and not my first drive for some reason? could this be why its giving me this error message?

 

anyway im a bit stumped, and pretty stressed out .....any help would do, i really dont want to go as far as formatting my comp so I would like to get some expert advice on this....thanks much

Share this post


Link to post
Share on other sites

As you can see by my post I'm a bit of a newb when it comes to this...How can I do that if I'm not even able to get into my windows? It gives me that error message during the boot up process.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...