Jump to content
Sign in to follow this  
Evil-Fruits&#124R4z

NF4 Venus & X-FI Problem

Recommended Posts

Ok, well everything was swell until I decided to install the X-FI now, after the software & Drivers(latest from web) are installed I am getting BSOD all the time, uninstalled and its fine.....

 

I have read the numerous threads arguing whether this is BIOS or Firmware related but,I would like confirmation on the current situation - do I flash the NF4 BIOS from the stock which it has atm or do I RMA the X-FI for a Firmware upgrade.

 

I bought the card OEM last week so, thought that maybe it be OK, looks like I was wrong :(

 

Thanks

R4z

Share this post


Link to post
Share on other sites

Use the drivers that came with the X-FI. I also went to the Creative website to load newer drivers but got no sound at all. I did a system restore point BEFORE I loaded the drivers and just did a system restore to the point before the install. It seems the latest drivers on Creative's site have issues, dont know if it is Mobo or just driver conflicts.

Share this post


Link to post
Share on other sites
I also went to the Creative website to load newer drivers but got no sound at all.
I use the latest Web driver (LB_2_09_0001) for my XtremeMusic without any issues. If you are running digital via the FlexiJack, you do need to set it up - it isn't done by default in this driver. Open the Creative Console and click "settings" and set the FlexiJack mode to "Digital I/O". You'll need to do this for both Game and Entertainment modes.
I bought the card OEM last week so, thought that maybe it be OK, looks like I was wrong :(
That might have been one of the older (1st revision) boards that were plagued with problems. I have the retail version in my eXpert (purchased March this year) with the heatsink mod and it works as expected.

Share this post


Link to post
Share on other sites

Well I emailed the Customer Support @ Creative and guess what 3 days later and no reply - plus made a thread in theforum and 'eff all repliesin that too - I hope that Creative aren'tburying their heads in the sand.

 

I am going to start an RMA on the cardto have the Firmware flashed just in case its that.

 

:( R4z

Share this post


Link to post
Share on other sites
I use the latest Web driver (LB_2_09_0001) for my XtremeMusic without any issues. If you are running digital via the FlexiJack, you do need to set it up - it isn't done by default in this driver. Open the Creative Console and click "settings" and set the FlexiJack mode to "Digital I/O". You'll need to do this for both Game and Entertainment modes.

 

FlexiJack? is that the digital out on the PCI card itself?

Share this post


Link to post
Share on other sites

Hi

 

I am also using a Venus with an X-Fi card (ExtremeMusic) I am using the latest drivers off of the web for both Xp Pro 32 bit and also the 64 bit all without any problems at all.

 

Out of pure curiosity which version (card wise) are you using ??

Share this post


Link to post
Share on other sites

I have experienced problems when installing ONLY the web driver and a friend of me had the same problems. When installing the CD driver first and then overwrite it with the latest web release everything seems to be fine... Good luck.

Share this post


Link to post
Share on other sites
FlexiJack? is that the digital out on the PCI card itself?
Yes, the very top jack on the backplate of the card. It's called the FlexiJack as it can be used for either Digital output or the Microphone.

Share this post


Link to post
Share on other sites

Ahem.......well I have sorted it out.

 

Turns out that I hadnt plugged in the auxilary FDD connector, so I made a lead as my PSU only has 2 to start with and they are both used and re-installed....low and behold it worked and updated to the latest drivers with no probs at all......

 

whoopsi.....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...