Jump to content
Sign in to follow this  
Choke

SATA drive not detected by Windows XP

Recommended Posts

As you can see in the image below, it is not shown at all. My system is in spanish but I am sure you will recognize each element.

 

screenhunter0016fp.th.png

 

The device shown as Disco 0 (Disk 0) is my IDE drive. SATA drive should show up as Disco 1, 2 or n.

Share this post


Link to post
Share on other sites

Try the drive in another rig or try another sata drive in your rig. If you try another drive in your rig and does not show would rma board.

Share this post


Link to post
Share on other sites

If I could understand correctly, not even in post screen the drive is detected. Am I right? Let only you SATA drive connected, go into the BIOS and check if you can see your SATA drive there. If not, the MOBO isn't detecting it and, this way, it isn't an OS issue.

 

Next step, taking the facts above as true, before sending the mobo to RMA, take your parts out of the case and build as described in the "INITIAL BUILD GUIDE" thread. After that, try clearing the CMOS as described here: http://www.dfi-street.com/forum/showpost.p...04&postcount=24

 

If, even so, things don't work fine, RMA is the only choice left.

Share this post


Link to post
Share on other sites

alexandre, check the following items in your BIOS;

 

INTEGRATED PERIPHIALS>IDE FUNCTION SETUP - all should be set at auto and enabled.

 

Double check that your SATA ports are enabled also, I know that you said you did that, but double check again, and only enable 1&2 or 3&4 depending on what SATA channels you are actually using.

 

Also disable SATA Spread Spectrum.

 

See if this gets you anywhere.

Share this post


Link to post
Share on other sites
alexandre, check the following items in your BIOS;

 

INTEGRATED PERIPHIALS>IDE FUNCTION SETUP - all should be set at auto and enabled.

 

Double check that your SATA ports are enabled also, I know that you said you did that, but double check again, and only enable 1&2 or 3&4 depending on what SATA channels you are actually using.

 

Also disable SATA Spread Spectrum.

 

See if this gets you anywhere.

 

LOL... wevsspot, this time is Choke who's having issues... my rig I'll check next weekend as I said there in the thread.

 

Even so, I'll also do that you've said.

Share this post


Link to post
Share on other sites

Following the advices of wevsspot I double checked BIOS again.

All IDE options are in auto.

SATA ports were enabled all 4 of them. I disabled 3&4 as I not use them. As result my devices manger screen changed. 1st image is with all 4 ports enabled. 2nd image is with 3&4 disabled.

Note that instead of 3 primary and 3 secondary IDE remains only 1 of each.

But still I have two PCI IDE standar double channel controller. One with the yellow mark on it.

May be this one belong to SATA ports? Should I try to change drivers for it to NForce drivers? I hear your suggestions.

 

 

screenhunter0027xl.th.jpg

 

screenhunter0013pm.th.jpg

Share this post


Link to post
Share on other sites

Choke,

 

It doesn't appear that your nForce chipset drivers are installed. Please download nVidia chipset driver version 6.70 directly from nVidia's website and run through the install routine. And are you using an official Windows XP installation CD? And if so, do you have SP2 installed also?

Share this post


Link to post
Share on other sites

Alexandre.ce made an interesting observation: does your drive show up correctly in bios?

 

What I'm about to say below is not directly related to your sata drive but we never really know what's the source of the problem so here it goes:

 

I noticed u got different file systems running on different partitions on the same physical drive. Not good. Get rid of that old fat32.

 

Check the jumpers of your IDE drive, make sure it's set to master and is connected to the primary IDE channel.

Share this post


Link to post
Share on other sites

Oh, sorry for the double post but I just noticed this:

 

Choke, did you say u formatted the drive using the "maxblast cd"? Isn't that program intended for use with maxtor hard drives? Your sata drive is from Western Digital, right? This shouldn't be a problem but you ARE having problems so I just thought I'd point that out.

 

Even so, an unformatted hard drive would still show up under windows...

 

We'll get to the bottom of this, you'll see... :)

Share this post


Link to post
Share on other sites

I think that jumpers on IDE drive should not affect SATA drive behaviour but just in case, I will try different combinations.

IDE drive is already conected as master on controller 1

DVD drive is connected as master on controller 2

 

Regarding MaxBlast tool, it has not the limitations as other manufacturer tools (like Seagate) that are only intended for their own devices. It detected the drive and formated it smooth.

Anyway, I will wipe out the disk and see what happens.

 

I updated the double port IDE controllers drivers with nForce drivers. Windows accpeted them so I have not forced anything. And two Storage devices appeared.

 

screenhunter0039pf.th.jpg

 

I am not sure what they are. May be the 2 partitions on SATA drive?

I will wipe the disk and look for changes.

Share this post


Link to post
Share on other sites
Alexandre.ce made an interesting observation: does your drive show up correctly in bios?

...

 

Then, is the driver correctly detected by the bios, isn't it?

 

I think that jumpers on IDE drive should not affect SATA drive behaviour but just in case, I will try different combinations.

IDE drive is already conected as master on controller 1

DVD drive is connected as master on controller 2

 

Regarding MaxBlast tool, it has not the limitations as other manufacturer tools (like Seagate) that are only intended for their own devices. It detected the drive and formated it smooth.

Anyway, I will wipe out the disk and see what happens.

 

I updated the double port IDE controllers drivers with nForce drivers. Windows accpeted them so I have not forced anything. And two Storage devices appeared.

 

screenhunter0039pf.th.jpg

 

I am not sure what they are. May be the 2 partitions on SATA drive?

I will wipe the disk and look for changes.

 

Choke, pls, get the DATA LIFEGUARD DIAGNOSTICS in WD website; the one intended to run under DOS interface. Boot up using that soft and see if it can detect your drive. If yes, select "WRITE ZEROS TO DRIVE" and perform the full (Extended) operation.

 

Well, if you can do that, surely your drive will be seen in Windows. That operation is just like taking the drive to the state of a new one. If everything runs fine, format your drive in windows, download the DATA LIFEGUARD TOOLS for Windows, install it and run. Certainly It will tell you that an operation is necessary in order to Windows take advantage of its full capacity. You'll need to click ok and the software will do the process automatically. After that, it'll ask you to reboot... just do so and I think things will be ok for you.

Share this post


Link to post
Share on other sites

I got the DOS Data Lifeguards Tools from WD as suggested and erased completely the disk. Windows don't detect the erased disk. Nothing changed.

The I partitioned the disk again. WD tool has a very similar GUI to MaxBlast (may be the same) but has some improvements. It allow to copy an entire partition, so it copied my existing partition on IDE drive to SATA drive.

I tried to boot from that partition, disabling IDE drive, but something is wrong and windows halts. Safe mode boot options appear but it don't boot in safe mode. Halts too.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...