Jump to content
Sign in to follow this  
52fitz

7.1 Onboard Audio with Games

Recommended Posts

Hey all

 

I have a 7.1 speaker system which seems to work fine for everything except games. I'm running the latest nForce audio drivers, and get 7.1 sound when using Itunes, listening to game trailers etc. When I select '7.1 speakers' in 'audio options' in games I just get 5.1 sound, with nothing coming out of the two rear speakers.

 

I've got Creative speakers, which only have 3 connectors for the PC instead of four, so I had to add in an extra lead to get the nVidia speaker wizard to give me the right sound from the right speakers. Okay, that's kind of a bodge, but it works fine in the wizard and in everything other than games.

 

Just wondering if anyone has had the same problem and found a way round it...

 

52

Share this post


Link to post
Share on other sites

have you enabled the 7.1 spkrs in the nvmixer? open nvmixer an check all settings to make sure you have all you spks enabled

Share this post


Link to post
Share on other sites

Open nVmixer, click on the second button from the left (on the bottom), Click surround settings, tick (enable) Clone as encoding option, Click OK and you are good to go.

Share this post


Link to post
Share on other sites

It doesn't need to support 7.1 for you to get sound from all your speakers, :rolleyes:

it just needs to support 7.1 if you want to have surround sound from your speakers :shake:

Share this post


Link to post
Share on other sites

Thanks for your suggestions.

>Suspekt, I really thought the 'clone' setting would work for me but it doesn't.

 

The only way I can get sound out of my rear speakers in a game like say HL2 is to use the '5.1->7.1 upmix' button on the Creative box. Trouble is, that's not really solving the problem :rolleyes:

Share this post


Link to post
Share on other sites

hmm, what soundcard did you say you have? what version of nVmixer?

 

I don't see the 5.1->7.1 upmix alternative in my nVmixer, only 5.1 and 7.1.

 

Note that in Windows Control Panel, Sound and Audio Settings -> Advanced

you have both 5.1, 7.1 and 7.1 wide

 

Maybe you can try to change from 7.1 to 7.1 wide?

Share this post


Link to post
Share on other sites

The 5.1 > 7.1 upmix button is on my Creative box (the subwoofer).

Everything is as it should be in Windoze control panel (mind you, I didn't know there was a 7.1 wide setting, which will be useful one day!)

 

Maybe I need either: 1. A set of 7.1 speakers with four leads that fit into the four sockets on the Karajan. OR 2. A Creative sound card so that the 3-plug connector that comes with my Creative box works properly...

Share this post


Link to post
Share on other sites

Oh, you had it on the Creative box :)

 

I can't think of anything more you could try... well maybe if there is some option in the game, like Software, Hardware, Hardware+Eax, 3D SOUND or something.

Share this post


Link to post
Share on other sites
maybe the game doesnt support 7.1 only 5.1

That's a possibility. But you should get sound from all speakers if the game uses the Windows driver. If it has it's own driver maybe that is the source of the problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...