Jump to content
Sign in to follow this  
Corpsman

Linux hijacks my network??

Recommended Posts

I recently installed a dual boot partition with Linux. The problem is, everytime I boot to Linux and go on the internet, then log off Linux and boot Windows... My network ceases to work. The green light indicating network usage is completely off. The only ways I have been able to fix this so far is to either completely uninstall the network adapter or remove the power cord from the back of the tower. Why is this happening?

Share this post


Link to post
Share on other sites

Describe your network setup, how's your internet connected and how are the PCs connected?

Share this post


Link to post
Share on other sites
Guest nibs

I've had similar issues to this as I often dual boot between Linux and Windows. I don't know what causes it, but my solution has been to use the Marvell Lan in one operating system and the nForce Lan connector in the other. Its a bit crude, but I no longer have headaches. I think it has something to do with how Linux brings up/ brings down the network connections when it boots and shuts down. I once had an issue where I was trying to install a second Linux and it would only recognize one of the LAN ports and not the other.

My board has always been kind of finicky with LAN ports though... took forever to get either of them to work when I first built my computer. Lately though, its fine. I might suggest a BIOS flash and then complete reinstall if you are up to it. Again the easy solution is just to use a different port for each OS.

Share this post


Link to post
Share on other sites

Hello :) my first post

 

martin, i've had same problem, this is driver problem, if you read README of driver in Troubleshooting section:

 

Problem: The driver can be started, but if an ip address is assigned

to an adapter no link up indication appears although it is

connected to the network. It is also not possible to receive

or transmit any packets; e.g. 'ping' does not work.

Reason: The adapter does not receive any interrupts from the Linux

system. This can happen when using the APIC (Advanced

Programmable Interrupt Controller) of an SMP compiled kernel

on a UP envrionment.

Solution: Use the Linux kernel parameters 'noapic' or 'nolapic' when

booting your kernel. This can be done by adding those kernel

parameters to the boot manager kernel selection menu (either

/boot/grub/menu.lst (GRUB) or /etc/lilo.conf (LILO)).

When you build a kernel, deselect option CONFIG_X86_LOCAL_APIC.

 

I tried this, but not work for me, my solution is power off PSU, and power on..

Share this post


Link to post
Share on other sites

Same here, you need to power down completely then boot into the other OS.

Share this post


Link to post
Share on other sites

OK, so this is dual-boot and the internet connection is one of the LAN ports to the cable modem or whatever?

 

I have no problems dual-booting a variety of NForce-GbE boards between Win2K and Linux. However, I pretty much always have the newest drivers. The NForce GbE driver was broken and semi-broken very often.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...