Jump to content
Sign in to follow this  
KimTjik

FF memory leak - some easy fixes

Recommended Posts

For them of you who want to optimize FireFox, or at least make it less memory hungry, here's some very easy fixes for you:

 

First to check:

1. In the address field write "about:config"

 

2. Search for the line "browser.cache.memory.enable" and make sure it's set to true

 

Another option:

1. Right-click anywhere in the "about:config" window and choose "New" and then "Integer"

 

2. In the field which comes up for "New Integer Value" write "browser.cache.memory.capacity"

 

3. Next you can set a value. If you look at MozillaZine you can see that the default value is "-1" and what that means. You could actually set whatever value you want (with the risk of having FF crashing if set to low), and I think that the next column "In Firefox 2 and SeaMonkey 1.1, these defaults will change to the following" gives pretty good guidance to which value you could use. I'm running FF with success at a value of 15000 and haven't experienced any problems yet.

 

This option works amazingly well:

1. Right-click anywhere in the "about:config" window and choose "New" and then "Boolesk"

 

2. In the field which comes up for "New Boolesk Value" write "config.trim_on_minimize" and then choose "true"

 

The funny thing is: by minimizing the window FF writes to the hd what was stored in the memory. I haven't experienced any performance problems and it certainly frees up a lot of memory.

 

I'm not smart in this, but have found some bits of information in different places, so I simply pass it on. I hope it might become useful.

Share this post


Link to post
Share on other sites

Yeah nice post ;).

 

I did'nt have to make any new settings though :.

 

browser.cache.memory.capacity

Was 0

 

What do the values mean btw?

Does 15000 = 15megs allmost?

15000 / 1024...?

I'm all for letting it have more then if that is the case, but I'll wait on the opinion of others on what the values mean 1st.

(EDIT: )

24576

That's what I'm gonna use for now.

I'm betting this is the amount of memory used for cache.

Funny though, I used to have this set to 16-32 before, I dn remember exactly.

It must of got setup to 0 when I moved to ver 1 or whatever, whenever the config dialogs changed.

I've been using firefox since it was alpha I belive, 0.7 or 0.6, whatever I can't remember.

Been using the same config since, updating it from time to time, etc.

 

browser.cache.memory.enable

Was set to true allready

 

config.trim_on_minimize

Was set to false.

Sounds good though, on true, if it saves the cache to the drive when minamizing, shoot, maybe we can actually save the cache before it exits, in those cases...

Instability cases.

(Edit: )

Err, then again...

When it does exit like that by iot's self, it does'nt allow it's self to read the cache, it allways reloads it completely ^^.

So this setting on true is probably worthless I'm afraid.

I'm setting it back on false now that I think about it.

 

I have had some huge probs with adobe acrobat and firefox intergration.

I'd much rather open it out of firefox and all...

That way it don't hard lock firefox.

I freakin hate that when it happens...

Messes up windows hardcore, especially on 2k.

Share this post


Link to post
Share on other sites

Admittedly, it seems worse now.

Ohwell, it's faster though.

 

I found this though, when I wne to update from 1.5.0.2 to 1.5.0.3 or whatever they are called...

Firefox 1.5.0.3 may hang when closing after viewing a PDF file in some older versions of the Adobe Acrobat Reader plug in. If you experience this, make sure you are using the newest version of the plug in.

Oui...

I'm not gonna update to an even more boggy acrobat.

 

Anyways found this too:

 

Poorly designed or incompatible Extensions can cause problems with your browser, including make it crash, slow down page display, etc. If you encounter strange problems relating to parts of the browser no longer working, the browser not starting, windows with strange or distorted appearance, degraded performance, etc, you may be suffering from Extension or Theme trouble. Restart the browser in Safe Mode. On Windows, start using the "Safe Mode" shortcut created in your Start menu or by running firefox.exe -safe-mode.

 

 

Sounds good.

I don't care about either function.

Probably saves memory and etc.

 

Edit:

Err, that safe mode thing sucks big time.

Share this post


Link to post
Share on other sites

just an FYI - if you dont want to download and bog down with acrobat go get foxit pdf reader. Its a standalone executable that is small and quick. I use it on all my machines. its fast + free, give it a try.

Share this post


Link to post
Share on other sites
Admittedly, it seems worse now.

Ohwell, it's faster though.

 

I found this though, when I wne to update from 1.5.0.2 to 1.5.0.3 or whatever they are called...

Firefox 1.5.0.3 may hang when closing after viewing a PDF file in some older versions of the Adobe Acrobat Reader plug in. If you experience this, make sure you are using the newest version of the plug in.

If "worse" has to do with Adobe Acrobat Reader, yes I have had problems with that too. In the past I couldn't use version 7 and had to use a older version; no big difference anyway. Now it's different: the latest versions of FF have worked flawlessly for me.

 

But I see NuLL's suggestion and it looks good. This is what I like in FF; you have all kinds of possibilities in getting in work more or less like you want.

Share this post


Link to post
Share on other sites

Cool I will try that pdf reader then :).

It would likely make pdf's open externally like they should be...

 

Has anyone tried the firefox 3.x alpha yet?

It's not even called firefox anymore, it's called minefield :.

I did'nt much like it at all, some settings would not stick, some under a diff name.

More menu entries permently stuck on, etc.

Slower too.

I hated it...

 

In any case, if firefox ends up becoming that thing, I'll stick with 1.x ^^.

Share this post


Link to post
Share on other sites

Firefox has always had problems with Adobe Acrobat Reader. Even using the full version of

Acrobat causes problems with Firefox. I don't even bother using it with Firefox. I just copy link location and open up IE.

Share this post


Link to post
Share on other sites

I use an extension called PDF download, which allows me to download the PDF (well, duh) and open it directly with Adobe. Works especially nicely in conjunction with the Download Statusbar extension (which is highly recommended in its own right).

Share this post


Link to post
Share on other sites
This option works amazingly well:

1. Right-click anywhere in the "about:config" window and choose "New" and then "Boolesk"

 

2. In the field which comes up for "New Boolesk Value" write "config.trim_on_minimize" and then choose "true"

 

The funny thing is: by minimizing the window FF writes to the hd what was stored in the memory. I haven't experienced any performance problems and it certainly frees up a lot of memory.

I've tested this option now for some time and works very well. It's like you're fooling the program, because after you've minimized the windows you simply pick it up again, but now it will slowly increase in memory from about 1/10th of what it was to max a half of it.

 

So with the tweaks made I've got about 10 tabs not going over 40 000 K, which I think is pretty good.

Share this post


Link to post
Share on other sites
For them of you who want to optimize FireFox, or at least make it less memory hungry, here's some very easy fixes for you:

 

First to check:

1. In the address field write "about:config"

 

2. Search for the line "browser.cache.memory.enable" and make sure it's set to true

 

Another option:

1. Right-click anywhere in the "about:config" window and choose "New" and then "Integer"

 

2. In the field which comes up for "New Integer Value" write "browser.cache.memory.capacity"

 

3. Next you can set a value. If you look at MozillaZine you can see that the default value is "-1" and what that means. You could actually set whatever value you want (with the risk of having FF crashing if set to low), and I think that the next column "In Firefox 2 and SeaMonkey 1.1, these defaults will change to the following" gives pretty good guidance to which value you could use. I'm running FF with success at a value of 15000 and haven't experienced any problems yet.

 

This option works amazingly well:

1. Right-click anywhere in the "about:config" window and choose "New" and then "Boolesk"

 

2. In the field which comes up for "New Boolesk Value" write "config.trim_on_minimize" and then choose "true"

 

The funny thing is: by minimizing the window FF writes to the hd what was stored in the memory. I haven't experienced any performance problems and it certainly frees up a lot of memory.

 

I'm not smart in this, but have found some bits of information in different places, so I simply pass it on. I hope it might become useful.

 

Shouldn't it be "New boolean" not boolesk???

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...