Jump to content
Sign in to follow this  
sudrin

Crossfire won't run

Recommended Posts

I recently built a CFX3200-DR motherboard with an ATI Radeon 1900 Crossfire Edition and a Radeon 1900XTX. I can enable Crossfire just fine in the CCC but when I go to run anything such as dxdiag or 3dmark it either crashes with a BSOD blaming ati2dvag, flashes to a black screen with a small blue bar in the upper left hand corner or the ATI driver reports the GPU stopped responding.

 

I have read other posts on here that discuss conflicts with Sound Blaster cards and I have tried disabling it, but still no luck. I have enabled writes between the two cards and tried it with all the obvious bios settings. The board is basically the default settings because I didn't want to start fiddling around until I had a known good configuration.

 

I've basically exausted all of my clever ideas including trying both the 6.3 and 6.4 versions of the drivers. I can run one card just wonderful, but the second card just wont enable.

 

Any advice would be greatly appreciated!

Share this post


Link to post
Share on other sites

sounds very similar to the issues i was having, mine seems to have been caused by having another HDD connected to the ULI SATA connectors, when i take it off my 3D is fine, put it in and i get black screen and a re-boot.

Share this post


Link to post
Share on other sites
sounds very similar to the issues i was having, mine seems to have been caused by having another HDD connected to the ULI SATA connectors, when i take it off my 3D is fine, put it in and i get black screen and a re-boot.

 

 

Yeah, I read your post.. I hope its not that since I have it set up for Raid 0+1 which requires all 4.

Share this post


Link to post
Share on other sites
What BIOS version?

Also did you enable the 10% extra current?

What do you have your RAM timings at?

 

I have the latest version of the bios. I've tried with the 10% extra and without, same version. My ram settings were at Auto but I've tried configuring them specficially for my ram with the same exact result.

Share this post


Link to post
Share on other sites

To further illustrate I have taken some shots of the screens I get. Its hard to describe what I'm seeing so maybe someone who has seen it already will know right away from these:

 

"<ahttp://www.sudrin.com/David/DSC06966 (Small).JPG" title="dxdiag possible result 1" >

This is the first and most common result

 

"<ahttp://www.sudrin.com/David/DSC06967 (Small).JPG" title="dxdiag possible result 2" >

Occasionally this happens

 

"<ahttp://www.sudrin.com/David/DSC06969 (Small).JPG" title="dxdiag possible result 3" >

Sometimes I get the above screen and then this a few seconds later

Share this post


Link to post
Share on other sites


"<ahttp://www.sudrin.com/David/DSC06967 (Small).JPG" title="dxdiag possible result 2" >

"<ahttp://www.sudrin.com/David/DSC06969 (Small).JPG" title="dxdiag possible result 3" >

Share this post


Link to post
Share on other sites

Okay, I took some pictures of what its doing since its easier to show than to explain.. Maybe someone has seen this before and will point me in the right direction

 

DSC06966%20(Small).JPG

This is the most common result

 

DSC06967%20(Small).JPG

Sometimes I get this

 

DSC06969%20(Small).JPG

Or sometimes I get the above followed by this.

Share this post


Link to post
Share on other sites

Hi,

 

My system only does the checkerboard pattern when the dongle is loose, I had forgotten to tighten the retention screws.

 

I trust p2p writes are enabled in bios?

 

Also Tony posted something about going into control panel>display>settings>advanced>troubleshoot then disabling write combining.

 

If this does not work and you have eliminated all other variables, I'd rma the cards and get replacements.

 

Crossfire works great once you get past the setup.

 

Even if games are not Crossfire initialised you can get around it by changing the executable file name for the game to AFR-FriendlyD3D

 

This forces the game to run in altenate frame rendering mode, which is the fastest (technically) of all Crossfire modes, you get quite a boost in frame rates. Especially in games that have not been profiled by ATI in CCC.

 

I downloaded the GRAW demo, with Crossfire, it is alleged to run slower than using a single card. I was getting 37fps with all details on max @ 1280X1024. When I changed the exe name to AFR-FriendlyD3D the frame rates increased to 80-90 fps.

 

 

 

Raja

 

 

edit: just noticed you have p2p enabled, try the write combining..

Share this post


Link to post
Share on other sites
Hi,

 

My system only does the checkerboard pattern when the dongle is loose, I had forgotten to tighten the retention screws.

 

I trust p2p writes are enabled in bios?

 

Also Tony posted something about going into control panel>display>settings>advanced>troubleshoot then disabling write combining.

 

If this does not work and you have eliminated all other variables, I'd rma the cards and get replacements.

 

Yes, I had looked thru other posts already and had set up the p2p writes. I have checked the dongle, if its not connected then I don't know what connected is. I've tried with and without write combing, and I've tested each of the cards independently and they seem to work. I can play my games just fine in a one card setup. This is making me sad.

Share this post


Link to post
Share on other sites

sudrin : i got same problems, not sure how i fixed it though, since then i sent card to RMA (before it it worked correctly) what i only changed probably was disabling 3.5" floppy disk and removing 2 DIMMs so only got 1GB RAM (got 4x512MB). Tried it with just 2 DIMMs?

Share this post


Link to post
Share on other sites

sudrin,

 

Your problem sounds very similar to the problem I’ve been having with getting Cross Fire to work. Here is a link to a discussion I had about this problem over at PlanetAMD64. With the first link it’s about eight posts down from the top, the second link discusses the same problem only with the Asus motherboard-

 

http://www.planetamd64.com/index.php?showtopic=21641&st=0

 

http://www.planetamd64.com/index.php?showtopic=21535

 

The only thing that I have been able to do to get Cross Fire to work is to first uninstall the catalysts and then reinstall them. I also tried reinstalling the Catalysts without uninstalling first but that did not work. This problem is bizarre to say the least.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...