Jump to content
Sign in to follow this  
gamester5

Where have all the Venus's gone? Where did they go?

Recommended Posts

Wow, still a few adding to the Venus board. Mine is still running strong with absolutly NO issues at all. I have not once had a single problem with this motherboard.

Share this post


Link to post
Share on other sites

Added myself also.

Venus #761, Rome - Italy.

Nice to meet you all.

 

---------------------

 

DFI UT SLi-DR Venus #761 BIOS 406 (04/06/2006) - AMD A64 FX-55 SanDiego 0513MPMW [email protected] (Mach II subzero on DFI SLi-DR) - GSkill GH UTT 1T/[email protected] 3.6V - Geil UltraX TCCD 1T/[email protected] 2.66V - 2x GeForce [email protected]/1720 SLi - OCZ ModStream 520W

Share this post


Link to post
Share on other sites

WOW, I think we located close to 50% of the Venus's. Not to bad. I still have mine but I am about ready to sell it. It is currently in a box I am no longer using.

Share this post


Link to post
Share on other sites

I tell you those are strong boards. I only did some minor overclocking for some benches and I NEVER had any hiccups, blue screens or any type of blip from my board. You never hear much about them anymore and you never really saw many issues with them, they are that good.

 

I have searched high and low to see if any have been for sale but not for a number of months have I seen any.

 

I have this system / below sitting in a corner.... damn waste, such a great computer

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...