Jump to content
Sign in to follow this  
mrsaturn

BIOS Update for X-Fi compatibility?

Recommended Posts

Yeah the X-Fi has THX, EAX 5, etc. Besides, I mainly want it for BF2 and Oblivion. M-Audio has nice specs and I bet it actually works the first go-around, but for the same price I want the features of an X-Fi.

Share this post


Link to post
Share on other sites

M- Audio are damn good dont get me wrong but they are like the audigy 2 zs's

 

and the X-Fi kick the hell outa audigy 2's wen u use the speaker setup i am using

Share this post


Link to post
Share on other sites

Hey before you leave could you whip up a quick BIOS fix? ;)

 

Bah!! I have such a love/hate relationship with Creative.

Share this post


Link to post
Share on other sites
Hey before you leave could you whip up a quick BIOS fix? ;)

 

Yeah no problem.

 

Seriously.

 

Edit:

 

Seriously though, try out NeoAethyrs suggestion, you might even be able to move it to a different slot. Or try installing it AFTER Windows is installed.

 

I'll let A_G know to stop by and give his advice, but in the past it has been basically the same as the one I already brought up. There isn't a helluva lot else you can do since it has already been brought to the attention of DFI. Sorry, thats just the way it is.

 

And by the way, keep this to one thread, we have more than enough on this subject already...

Share this post


Link to post
Share on other sites

Yep, I already accepted that and have it packed up and ready to go back. I was just hoping someone had a silver bullet.

 

I've tried everything, including all the things mentioned.

 

Thanks for the help though, I do appreciate it. Everyone responded very quickly.

Share this post


Link to post
Share on other sites

I have one that has not given me any problems. I did not order one until I knew I would have the "revised hardware fix". It is possible you got an older one. I do not know where you got yours from.

I thing for sure it has to go in the bottom slot. It is an awesome card and should work with your system.

My system was up and running before I install my card. I also install the drivers from their web site(creative). I wanted to make sure I have the lastest and greatest driver.

The sound card makes a big difference in every game I play and every song I play. I also coax my connection to my speaker to get digital. I hope you get your new one soon.

Check my bios date in my system and see if you have the same one. After that you make sure you have the sound shut off in the bios for on board sound. That just leave one thing left and that is the card itself with the latest drivers.

Share this post


Link to post
Share on other sites

So have we verified which bios the X-FI comes with that have problems or the version of the fixed bios? I'm getting an X-FI ExtremeMusic soon for my lil' brother for his ASUS A8R-MVP, but i was going to give him my Sound Blaster Audigy Gamer, LOL!

Share this post


Link to post
Share on other sites

Once the card is installed into the system, there is a utility to run to see which firmware version is on the card.

So have we verified which bios the X-FI comes with that have problems or the version of the fixed bios? I'm getting an X-FI ExtremeMusic soon for my lil' brother for his ASUS A8R-MVP, but i was going to give him my Sound Blaster Audigy Gamer, LOL!

Share this post


Link to post
Share on other sites

for anyone having X-Fi problems:

 

you will have to send your card back to creative to have the firmware updated as DFI has no plans to fix a bios for this issue

 

(don't yell at me, I am simply relaying the truth from DFI...I have asked them to fix it myself but no can do apparently...so it's up to you to get your Creative card reflashed or change motherboards, sorry)

Share this post


Link to post
Share on other sites
Hi kam33mitch, I've been following your posts on this board and the Creative thread. I believe you've been the most help to me (much more than Creative). Do you know what the revision is on your box? It has it on the bottom above the serial number. If I know this then at least I know what to hunt for. I've also heard that anything above 541 (or something like that) in the 9th, 10th, and 11th digits of the serial number will have a new firmware, but I proved this wrong :(

 

Anyway, thanks for the info. Hopefully I can get my hands on a working X-Fi soon.

 

Sorry, I'll have to open her up when I get home and check the numbers. I can tell you though that the easiest way to tell is to just put it in and turn it on. With the old model, even when it would boot and run OK, still started up with a huge list of unknown devices while booting (not in windows though). The new firmware just lists the devices with nothing unknown. The problem is 100% handled with the new firmware.

 

I know it is a real pain to send it in but in the very long run it will probably be worth the 2-3 weeks without it. I was about to do the same thing before my brother-in-law bought his rig and we traded.

Share this post


Link to post
Share on other sites

The X-fi problems are with the first model. Creative launched a revision that solving the problem, but some shops have the first edition stock and nobody can be sure to buy the correct. If you have problems send it back.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...