Jump to content
Sign in to follow this  
EnlargedTestie

Blue screen Problems

Recommended Posts

I keep Getting a blue screen on this computer. it says No More IrP Stack Locations. Any Idea? Hardware/software? anything. Thanks

 

Happens Durring Half life 2 and Fear.

Specs:

fx-57

dfi ultra-d 7/04-2bta

xfx 7800 gtx

2x WD Raptor 34g Raid-0

ocz modstream 500w

4x512 ocz platinum rev.2 3200

 

This system is not overclocked.

 

Also when I Boot my computer it says my ram is running at 333mhz. Shoudlent it be 400 mhz.

Share this post


Link to post
Share on other sites

Well I am not sure what IrP stands for but "stack" generally refers to a type of memory managment system that avoids the use of registers. So this is probably an error referring to a specific storage mechanism.

 

As for 333 and 400...DDR400 (aka PC3200) does not mean 400MHz per module, it refers to both modules operating in dual channel. Thus 200MHz+200MHz=400MHz which is DDR400. I am not sure where you are reading "333MHz" but if you got that from CPU-Z and you are running in dual channel then that means you are effectively running DDR666 (which I dont think you are).

If I were to guess where you read that, it was at POST, but you missread it. It probably says DDR333. If you are running in Dual Channel then your modules are each running at 166.5MHz which is more likely the case. I am not too familiar with that board but you can try changing your Tref for your DRAM to 2064 (the second one in the list). I say this because I had the same problem with my board.

 

Also, if you dont have CPU-Z I would suggest you download it can take the RAM SPD values listed in that program and set your BIOS to those, some mobos will set the memory to other values if under AUTO which can create problems such as yours.

Share this post


Link to post
Share on other sites

The 333mhz is just the divider you're running at, you probably have it set on auto.

 

Souns like you should run memtest on your sticks with the error your getting, could be you just don't have the correct timings plugged in too.

Share this post


Link to post
Share on other sites

the ram is running at 166 mhz. Sometime last week i changed it to 200 mhz to see if that would fix the problem but it did not. I ran the DFI Bios memtest95 last night for 7 hours with no errors. After toggling the sticks of ram their has been no freezes(Quite frequent before). I have also heard this could be a video driver issue. Would you happen to know if the 7800 gtx is a series 7 chip? because when I goto the xfx site to download drivers all i can find is the series 7 drivers which support the 7800 gtx 512, but it doesnt say anything about the 256mb card. Thanks for your help, once again.

 

Specs:

fx-57

dfi ultra-d 7/04-2bta

xfx 7800 gtx

2x WD Raptor 34g Raid-0

ocz modstream 500w

4x512 ocz platinum rev.2 3200

Share this post


Link to post
Share on other sites

Still getting random shut down in games. I have tested all of the sticks of ram in the single orange slot and they worked fine. They are still somehow running at ddr333 set from optimal settings. Should I be changing this to DDR 400? Or messing with any other ram settings?

Share this post


Link to post
Share on other sites

Hmm, random In game reboots. I have Tested all the ram, used all 4 stick and tried 2 and 1, tried several different video drivers. Still getting the same in game freeze. any suggestions.

Bios was set to optimized defualts, video settings are correct, clock default 2.8. Ram running at ddr333 default..

Any suggestions?

Specs:

fx-57

dfi ultra-d 7/04-2bta

xfx 7800 gtx

2x WD Raptor 34g Raid-0

ocz modstream 500w

4x512 ocz platinum rev.2 3200

Share this post


Link to post
Share on other sites

You can try setting your RAM timings to the ones specified in CPU-Z or from your manufacturers website; instead of leaving them on auto. Sometimes mobos will tighten the timings automatically even though that is not what the SPD has for timings.

Share this post


Link to post
Share on other sites

I got your answer buddy :), wierd though...

Not a commen problem, I had to look up the tweak only to find out poeple were getting that same bsod.

So I know what to do, I hope lol...

 

Here goes, lemme dig that sucker up...

 

HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSession ManagerI/O System

 

"LargeIrpStackLocations"

Dword

 

Default on 2k(any varient) is 7.

I suggest you make this key and setting, then try 7 or more until it stops ;).

I really hope this helps.

 

 

Can you give us some more info on what happens, or what your doing, or what it says on the bsod?

I'm wondering what causes it.

 

Oh yeah...

Um lemme think, roll a smoke and see if I can remember.

Hmm all I can remember is that you can lower it to 5 or disable it if you got somehting else going, but I forgot...

Lemme look it up.

Good thing you mentioned this, I forgot to write it down for later to add to my tweak files.....

 

 

Oh yeah :), linky:

http://www.microsoft.com/ntserver/docs/Fil...Performance.doc

 

Direct ref:

 

HKLMSYSTEMCurrentControlSetControlSession ManagerI/O System LargeIrpStackLocations=x7 (REG_DWORD)

 

LargeIrpStackLocations was set to 7 because the disk performance counter was enabled to collect data on disk IO operations. If the disk performance counter is on and LargeIrpStackLocations is not increased to 7, the IRPs for disk IO are larger than the pre-sized look-aside list allocation size, which causes the IRPs to be allocated from non-paged pool rather than the look-aside list. If the disk performance counter is turned off, LargeIrpStackLocations can be set to 4 or removed. An additional 2 to 3 percent system throughput and performance may be gained on some systems if the disk performance counters are not collected.

 

NOTE: The number of LargeIrpStackLocations required increases in the Microsoft Windows 2000 operating system, and the value may have to be increased accordingly.

 

 

It means if you do this:

HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlI/O System

"CountOperations" dword, = 0

Then you can do the irp thng at 5 or lower.

I remmeber now :).

The above countoperattions is correct, if you look it up on google they have it worng, I got my location off the msdn.

 

Good luck.

Set the count operations to 0.

Then set the irp thingy to 5 and start from there.

Set to 0, or perhaps 7, try diffrent ones to check.

Whatever lol :).

 

Edit:

Oh 4 sorry, one off lol.

What os are you using though dude?

An oem or retail, what ver?

 

Oh yeah, another reason I know my count operations locatian is correct is because it disables a few io counters in the task manager.

 

 

 

Another edit:

The irp stack seems to handle specificly disk io.

You can chnage the stack size if you got a server os(you could probably doit anyways...).

Though I think the location for the setting is in a server specific location on the registry...

 

 

You best bet is to disable any and all io counters.

Like I said before with the countoperations tweak, and now this one:

 

DISKPERF -N

 

Just to be safe about it, just in case it was talking about one or the other...

Run the above one in the cmd window or run bar thingy.

 

You may have to disable performance counters for other devices as well...

 

An example of such:

 

[HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpipPerformance]

 

"Disable Performance Counters"=dword:00000001

 

If you have a say a scsi or ide driver running that you are actually using, it might not hurt to make the performance key and throw that setting in there.

A real way of checking to see if such a counter exist, liek the one above is to run a program called:

exctrlst_setup.exe

 

Look it up, you can get it from ms's site.

That's only for the 1 above.

You can doit with this program too, as well as see what is setup for any service.

 

Afterwards, chek the game and what not.

If it's still having the same prob, increase the irp stack locations one at a time, start at 4.

Hopefully you can figuer this all out...

Share this post


Link to post
Share on other sites
...

As for 333 and 400...DDR400 (aka PC3200) does not mean 400MHz per module, it refers to both modules operating in dual channel. Thus 200MHz+200MHz=400MHz which is DDR400...

 

ddr 400 is 400MHz per module. ddr = double data rate, where data is sent on both the leading and trailing edge of the wave. 200MHz x 2 (ddr) = 400MHz for each stick, whether they're running in dual channel or not.

 

I am not sure where you are reading "333MHz" but if you got that from CPU-Z and you are running in dual channel then that means you are effectively running DDR666
no, see above. He is running his memory at 166MHz. 166 x 2 (ddr) = 333MHz.

 

The reason why you're running ddr333 instead of ddr400 is because you're using 4 sticks and too many auto settings.

 

Disable cpc so you run at a command rate of 2T. Set max memory speed to 200MHz. Run memtest86 for at least 3 hours to test memory stability, 8 hours with no errors is preferable.

 

Enlarged, go to the Stock Speed Database and find your RAM. There you will see what guys with your ram are doing... adjust accordingly, but plz do pay close attention, and do not go crazy with voltages. Use memtest religously.

Share this post


Link to post
Share on other sites

meh... no problem. Sometimes I skip the glass and drink it straight from the bottle too. ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...