Jump to content
Sign in to follow this  
RedDwarf

Trouble with suspend and hibernate

Recommended Posts

I am having trouble getting suspend and hibernate to work correctly. When I try to suspend or hibernate my PC restarts and does not shut down. I believe it should shutdown like a power off shutdown, but the power light should flash when in suspend.

I have tried changing the HAL as it defaults to ACPI uniprocessor PC, when I change to Advanced Configuration and Power Interface (ACPI) PC (I have only tried this by changing the driver in device manager) my monitor does not power off (which is important to me) although my PC does suspend and hibernate correctly. So as it is I can choose one or the other and not have everything working correctly together.

 

Does anyone have a solution to this?

Share this post


Link to post
Share on other sites

Is there any way to get it working on the current install? I don't really want to have to install again, I only installed a few weeks back.

 

[edit]

 

I nlited my windows CD and I do remember it having the option to select PC type while doing that nlite CD. I did not select the "correct" one because of the problems I had had when changing to that in device manager (the display not powering off)

Share this post


Link to post
Share on other sites

You can change the Computer Type in Device Manager to the Advanced Configuration

and Power Interface (ACPI) PC type without having to reinstall. You'll need to select

that type manually, choose the driver yourself, and then a couple of reboots is in order

for it to reallocate and take hold.

 

I'm unsure with the Suspend and Hibernation modes if you'd actually need a clean install

or otherwise, but you could try changing the type without reinstalling first and see

how that goes.

Share this post


Link to post
Share on other sites

I did already try that as I said above, but it totally screwed my monitor sleeping. It totally refused to sleep. The suspend and hibernate worked fine though. That is why I did not auto select that when I did the nlited windows cd, because I was concerned that it would not allow my monitor to sleep.

Share this post


Link to post
Share on other sites

Did your monitor go into sleep mode okay before switching the hal over?

 

What do you have these options set to? ~

(need any changes there?)

Power Management Setup

ACPI Function -

ACPI Suspend Type -

Power Management -

Video Off Method -

HDD Power Down -

Soft-Off by PBTN -

Wake On LAN From Soft-Off -

Wake On Ring From Soft-Off -

USB Resume from S3 - Disabled

Keyboard/Mouse Power On -

PWR Lost Resume State -

Power on by Alarm -

 

^

^ Might help in figuring out what's going on, but loggan mentioned that

a reinstall could remedy the issues you're having. Otherwise you might

need to go into Windows at the Services and/or Components level and

get into loading/configuring those and etc.

 

Also, how about a different driver for the monitor you have? The CPU?

 

I haven't messed to much with the hibernation and suspend modes much.

So you could wait for someone else to post in here relating to those.

 

PS - Apologies for missing that you had mentioned already using the ACPI

(ACPI) PC hal, just took a quick initial glance.

Share this post


Link to post
Share on other sites
Did your monitor go into sleep mode okay before switching the hal over?

 

yes it did and does now.

 

What do you have these options set to? ~

(need any changes there?)

Power Management Setup

ACPI Function -

ACPI Suspend Type -

Power Management -

Video Off Method - DPMS

HDD Power Down - 15 MINS

Soft-Off by PBTN -

Wake On LAN From Soft-Off - OFF

Wake On Ring From Soft-Off - OFF

USB Resume from S3 - Disabled

Keyboard/Mouse Power On - OFF

PWR Lost Resume State -

Power on by Alarm - DISABLED

 

^

^ Might help in figuring out what's going on, but loggan mentioned that

a reinstall could remedy the issues you're having. Otherwise you might

need to go into Windows at the Services and/or Components level and

get into loading/configuring those and etc.

 

I will check these and post about when I reboot I have filled in the ones I can remember, I am doing something which I cannot stop ATM.

 

Also, how about a different driver for the monitor you have? The CPU?

 

It's the driver for my monitor (iiyama crt), the only one I have and AMD mobile Athlon

Share this post


Link to post
Share on other sites
You can change the Computer Type in Device Manager to the Advanced Configuration

and Power Interface (ACPI) PC type without having to reinstall. You'll need to select

that type manually, choose the driver yourself, and then a couple of reboots is in order

for it to reallocate and take hold.

 

What driver would you choose to change this? Where do I find that one?

 

Thanks

 

Syn

Share this post


Link to post
Share on other sites

Okay I have rebooted and checked the Bios settings now. Here they are:

ACPI funcion Enabled

ACPI suspend type S3(STR)

Power Management User Defined

Video Off method DPMS Support

HDD Power down 15 mins

Soft off by PBTN Instant off

Wake on Lan from soft off Disabled

Wake on Ring from soft off Disabled

USB Resume from S3 Disabled

Keyboard/Mouse power on Disabled

Power lost resume state Kept Off

Power on by Alarm disabled (doesn't seem to work with this Bios.)

Share this post


Link to post
Share on other sites

Let the power management part do it automatically, you have your HDD to sleep i think after 15 min this might cause your prob, i dont know cause i dont really mess with hib/sleep, you could try though, power management on auto. All of that stuff in my bios i have never touched and my hiber/standby are working i tried, all stuff is defaults in that part of the bios, try setting to defaults and see if it helps.

Share this post


Link to post
Share on other sites

But your using the Advanced Configuration and Power Interface (ACPI) PC driver right? When I changed to that the suspend/hibernate did work correctly, it shutdown the PC and it stayed in soft off and did not restart my PC like it is doing ATM. That was with my current BIOS settings, the only problem I had was my monitor would not sleep and this is a big problem for me as I use this more than I use suspend/hibernate (only occasionally would I use hibernate and I am unlikely to use suspend)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×