Jump to content
Sign in to follow this  
Treebeard1337

x1900xt dosent fit right in slot

Recommended Posts

Well although I haven’t gotten this installed yet due to the fact that I don’t have the right power adapter to give the card its power, I did find out today as I was trying to install the card, that it didn’t seam to fit just right. Although it fits into the GPU slot just fine, the metal faceplate on the back doesn’t fit snug against the computer backing. Instead it seams to fall about a few centimeters short, and although it doesn’t seam much, it does prohibit me from inserting the screws that I need to keep it in place sturdily. If I forced it towards the back of the computer im afraid it could break off in the GPU slot, but if I don’t, I’m afraid it will break when I try to plug the monitor in and it doesn’t have anything to hold it in place except the GPU slot again. Anyone see a solution to this problem?

 

PS. My other two x800 cards that im replacing fit fine in both slots.

 

PPS. Ive got the card in the top slot, closest to the processor on the mobo, although I could move it down to the other slot maybe, I would prefer not to since I would have to move my hard drives, plus I think their both the same distance away from the back of the computer so I don’t know if it would matter.

Share this post


Link to post
Share on other sites

Its the metal PCI Bracket at fault, my X850XT does the same thing, i just push the tab so it aligns with screw holes and go for it. :)

Share this post


Link to post
Share on other sites

I would blame the pc case. I've seen the same card be fine in some and have the same prob you describe in others. Wont harm anything to force it a little for the screws:)

Share this post


Link to post
Share on other sites

set one of your x800s tha fit fine in the case on top tof the x1900,where the printed circuit board plugs into the top PCIE slot,line them up on the 2 cardsand see if the screw plate is out as much as you say it is,mabey it can be adjusted with screws mounting the mounting plate to the pcb.and make sure your pluggin it in the slot i havewater cooling and my case is a bit cramed with hoses andwires galore,when i added my master card i didnt even have the slave in thedamn slot:)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...