Jump to content
Sign in to follow this  
joelatino

DFI Expert:are there any new bios?

Recommended Posts

The 12/07 bios also screws up SLI big time. I tried it and i couldnt get SLI to go no matter what. So i flashed back to the original bios. After that my 2nd card still wasnt getting recognized so i decided to uninstall my vid card drivers. when i re-booted to install the Vid drivers my pc froze up. No mouse, no keyboard nothing works. Im on the verge of wiping out my os and reinstalling windows. What a pain. I should have stayed with my Asus.

Share this post


Link to post
Share on other sites
Try here

 

Great, thanks for the link! I thought the only BIOS version available at DFI.com were the 4 official versions? I had heard of those BIOS versions before but it's nice to have some description about what they are and what changes they make!

Share this post


Link to post
Share on other sites

Has anyone heard, or has anyone tried to use Venus BIOS on Expert? I certainly wouldn't try it without knowing first if it's cool but many have made the connections that both boards are very similar. Just curious guys, thanks.

Share this post


Link to post
Share on other sites
Has anyone heard, or has anyone tried to use Venus BIOS on Expert? I certainly wouldn't try it without knowing first if it's cool but many have made the connections that both boards are very similar. Just curious guys, thanks.

 

I am currently trying to find out about compatibility. It is indeed a new bios dated 1/17/06. The Venus IS an Expert mobo with a cap mod. I should be compatible I think, but I'm waiting for official word.

Share this post


Link to post
Share on other sites

O.K, thus far I'm a bit surprised by this board. On one hand, the HTT scales like mad (at 340 x 8 stable right now), on the other hand I cannot even post if I select the 9 x 300! Somehow I have been deprived the use of the 9x Multi by the 11/25 BIOS. With BigToe's mod, I can't even POST with 2 sticks. As for TCCD, just forget it...no post with any BIOS. Lets say I'm very disappointed. This board looks very good electrically and runs very cool, but if only we could get a nice stable and reliable BIOS.

 

Another thing is that NO PCI device is working. I just don't know why. These are reliable devices, right?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×