Jump to content
Sign in to follow this  
naddie

IDE at Auto = CHS???

Recommended Posts

Why does the BIOS uses CHS when set to AUTO? Conventional tech wisdom says LBA should always be used (nowadays).

 

I just found out my Seagate 300GB HD is on CHS.

 

 

ALSO - I noticed when I install Windows, it insists on using the PATA drive as the C: drive. However, when I try to turn off the HD from the BIOS (choose "None" instead of Auto), the POST shows that the hard drive is not detected (what I wanted), but once I start installing Windows XP, it shows up as one of the drives you can install Windows on!

 

Are these firmware bugs? I am using the C07 Bios (the one released on Dec - iow, the newest one).

Share this post


Link to post
Share on other sites

There are a couple of conventions that most BIOS writers follow that we never will get used too.

 

The second thing you noticed shows just how far Windows will go to ignore your wishes.

 

Why does the BIOS uses CHS when set to AUTO? Conventional tech wisdom says LBA should always be used (nowadays).

 

I just found out my Seagate 300GB HD is on CHS.

 

 

ALSO - I noticed when I install Windows, it insists on using the PATA drive as the C: drive. However, when I try to turn off the HD from the BIOS (choose "None" instead of Auto), the POST shows that the hard drive is not detected (what I wanted), but once I start installing Windows XP, it shows up as one of the drives you can install Windows on!

 

Are these firmware bugs? I am using the C07 Bios (the one released on Dec - iow, the newest one).

Share this post


Link to post
Share on other sites

So are we suppose to use CHS or LBA?

 

As for Windows igonring the BIOS, I thought the BIOS was at a level lower than the OS. If the BIOS is suppose to ignore the HD, then any OS should not be able to see the HD because the BIOS says so.

 

Is this kinda fishy?

Share this post


Link to post
Share on other sites

I have 2 Seagate 160G disks, #1 - ST3160023AS, #2 - ST3160827AS

 

Well, guess what. With "Auto" set in BIOS #1 appears LBA and #2 CHS :confused:

 

Go figure.

 

Changing both to "Large" works the same

Share this post


Link to post
Share on other sites

I noticed teh windows drive thing...

 

To me it's one of those: "We know you don't know how to operate a PC, after all, anybody that turns off one of thier devices in the bios is a tard!" things that microsoft is oh so good at doing. It's what's earned thier offering the term "stable"... if stable is questioning everything you do so you don't do anything stupid...

Share this post


Link to post
Share on other sites

I found something interesting that kinda fits here. I am booting of a SATA drive, everything is fine. I have 2 IDE HD attached to primary and 2 CDs attached to secondary. If I turn on the primary IDE in the bios I get constant reboots at windows. If I turn the IDE primary off in the BIOS, Windows boots and the IDE primary channel HD's are available in Windows. This is the only change that I make in the BIOS for a good boot. I have selected the SATA as the first boot device. I am using the Nvidia channel. This is more of an annoyance than anything.

Share this post


Link to post
Share on other sites
I have 2 Seagate 160G disks, #1 - ST3160023AS, #2 - ST3160827AS

 

Well, guess what. With "Auto" set in BIOS #1 appears LBA and #2 CHS :confused:

 

Go figure.

 

Changing both to "Large" works the same

 

 

Yep same for me. The first disk is Maxtor Sata 1 drive & is detected as LBA, second disk is a Samsung SPinpoint Sata II drive & is detected as CHS. Performance tested in windows shows the drives to be about even so surely something is wrong.

 

Changing to large does nothing. What gives DFI techs??

Share this post


Link to post
Share on other sites

Hello,

 

You should always be using LBA.

 

When you get a new pc or driver, always set it to LBA.

This effects how the drive maps out all the clusters/sectors.

Share this post


Link to post
Share on other sites
Hello,

 

You should always be using LBA.

 

When you get a new pc or driver, always set it to LBA.

This effects how the drive maps out all the clusters/sectors.

 

I would if the option was there!

Share this post


Link to post
Share on other sites

No, the only options are auto & large (which is not the same as lba), interestingly enough the drive is now reporting as a 137g, instead of 250g & is now in LBA mode. I can't seem to get it to report the correct size even using a samsung dos tool which just errors out when I try to change the LBA size to 250g.

Share this post


Link to post
Share on other sites

Sometimes the BIOS detects my 300GB HD as 137GB, too. I dunno why. But once in Windows, it sees the whole 300GB.

 

As for Windows trying to be idiot-proof, that's not the case. Windows is a high-level OS. BIOS is very low-level. The BIOS is the boss of Windows (and any other OS that you decide to run).

 

So that means that the firmware is SHOWING the user that it turned off an IDE channel, but it really didn't.

 

ALSO - there is absolutely no way you can run a 300GB in CHS. If you do force it to CHS mode, you are suppose to only see 8 GB of HD space. Of course, obviously, this is not the case here with the Expert firmware. In fact, this is why I originally missed the fact that it was auto-set to CHS - it is because Windows XP sees the entire 300 GB HD.

 

Those who say Windows XP is just trying to be idiot-proof, can you confirm this with another OS? Either yourself or someone else who is experienced with another OS other than Windows XP.

 

I might try Windows 98, since I am not very experienced with Linux. I will bust out an old HD thats bigger than 8GB (maybe a 120GB) and 1st try to see if it will see a HD when I turn it off in the BIOS. Then I will try CHS mode and see if win98 only sees 8GB or the whole 300GB.

 

If all other OSes have the same behavior as XP (sees the drive even when told to be OFF, and see the whole drive in CHS), then it is not an OS issue - it is confirmed to be firmware.

 

And for those who wonder why sometimes it detects your HD as a 137GB even though it is actually bigger.... well, I can't expalin the behavior here on the Expert firmware, but that magic number (137 GB) is the limitation of the 28-bit addressing using LBA. Well, new motherboards (ALL nF series of chipsets) now support 48-bit addressing, which has a new limitation of 144 Petabytes.

 

Read more info here: http://york.gose.org/pipermail/yorkcc/2003...ber/000075.html

 

Again, the Expert's native ATAPI IDE interface should be able to address 48-bits LBA - so I don't know why sometimes it reports our HDs as 137GB as if it was only a 28-bit LBA.

 

Something about the IDE/SATA detection is fishy on the Expert boards. Not sure if it's firmware, chipset, or other circuitry in between.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×