Jump to content
Sign in to follow this  
TerminallyOdd

X-Fi Woes

Recommended Posts

I'm not going to ask for help in getting it to work since I now realize (after buying it) that I'll need to wait for a new BIOS or get a replacement from Creative with a firmware upgrade. Basically, my whole system crapped out after putting this card in there.

 

My question, however, would be whether or not I should return it and get an Audigy2 ZS or Value or whatever. Does that card model fair better on DFI nForce4 boards? Is it worth it in sound quality difference as to justify waiting on that BIOS or pushing Creative to send a flashed new one my way?

 

I'm not much of an audiophile, and I'm moving up from a SB Live! 5.1. I've got crappy 2.1 speakers, but a good pair of Sennheiser headphones if that helps. It'd be for gaming and music.

Share this post


Link to post
Share on other sites

Is there any word on when DFI is releasing a BIOS that addresses this issue?

 

I'm not even sure my non-audiophile ears would notice a difference between an Audigy 2 card and this, so I'm kind of hoping for some idea as to how long this waiting game might be. I don't know if I want to deal with the shipping and waiting for 10-15 business days for the firmware upgrade. It'd be real nice if they let us take care of that ourselves.

Share this post


Link to post
Share on other sites

Every time I see another person saying they have no problems with a DFI nForce4 board, it makes me seem like I did something wrong...or that I could have worked around it...or that I could have removed another component that was causing the conflict.

 

Hmmm...anyway, I returned the X-Fi and ordered an Audigy 2 ZS Platinum off of buy.com, which is a measly $65 after $100 rebate and $10 first time buyer coupon. Doesn't seem to be listed ont he site anymore, but zipzoomfly.com has the same offer.

 

I hope I have an easier time this time around.

Share this post


Link to post
Share on other sites
Does the onboard audio suck or something?

 

Onboard sound sucks on most all mobos, this one isn't terrible but sure isn't that great either.

Share this post


Link to post
Share on other sites
Does the onboard audio suck or something?

 

Well, I wouldn't say it sucks. Actually, it sounds pretty damn good with music when I enable the equalizer.

 

It sounds pretty bad with games, though, for whatever reason. I'm not picky, but it just really lacks clarity. The sounds are a bit muffled and grainy. Plus, a soundcard will give me better performance, so that's definitely a plus.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×