Jump to content

Mysteries with Radeon X550, PCI-E slots and "no display"


Recommended Posts

I have never seen something like that... yet it happens and I'm simply wondering.

 

Here's the setup I've used for many months without any problems:

 

* DFI nF4 SLI-D bios 5-10

* 2x512 meg OCZ VX PC3200

* Voodoo3 PCI video card (was Radeon X800XL before, sold because of upgrade, but the upgrade has not come yet ;), recently borrowed an X800 for a lan party as well, had absolutely no problems)

* various harddrive configs, right now it's 2 SATA, 1 IDE plus a Liteon DVDRW drive.

* PCP&C 510W

 

Now I decided to buy another value video card so that it powered my everyday rig (as I've got a Dothan setup as well).

 

So I got myself a Radeon X550.

 

Took the Voodoo3 out, put the Radeon into the "2x PCI-E slot" (although they were configured as 8x - 8x for me with the SLI jumpers). Powered the rig up... bang! display remains black.

 

Hey, I thought, wtf. Checked all the cables. Rebooted. Waited a while, saw harddrives spinning, the keyboard Capslock and Numlock keys work, indicating the board has gone through POST (and no LED's were on as well), and already booting Windows (saw the FDD being accessed etc). But no display.

 

Took the Radeon X550 out. Put it in my Dothan rig (it's Asus P4GD1, so i915P with PCI-E). The card worked perfectly, the system posted, made to Windows etc. So obviously, it should work on DFI as well.

 

Put it back into my DFI nF4. Again, black display.

 

Put the Voodoo back into DFI. Everything was fine again. Went to bios, checked, the "init display first" was set to PCIEx. Changed to PCI this time (who knows). Put the Radeon X550 in. Was greeted by black display again.

 

Removed the fan from my Thermaltake Sonic Tower cooler so that I could put the card into the PCI x16 slot. This time, no POST. Rebooted, tried Insert and clear cmos, no POST. Played around more without any success.

 

Finally switched the SLI jumpers from 8x - 8x to 2x - 16x configuration.

 

Put the card into the 2x slot. Again, the board POSTs, and makes it to Windows, just with a black screen.

 

Put the card into the 16x slot. Finally was able to POST and get the picture. That means I've been left with no fan on my Sonic Tower since there's no more space for it. The card works, just the 2x PCI-E slot issue remains a mystery.

 

Anyone's got an idea, why this is happening? Is the 2x PCI-E slot half-dead or what?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...