Jump to content
Sign in to follow this  

NV Lan problems =(

Recommended Posts

It's been about a month or so since I've had my system. I should thank everyone for their support here. I haven't had major problems, and mostly all my posts related to pre-build questions.


Anyways, I had only 1 problem and that was NV Lan not working. I've tried 6.66 and the last 2 revisions as suggested by AG. No go. It obtains IP address for like 2 minutes before going to 167.blah.blah.blah. I hope my router isn't the issues (Linksys WRT54GS). Marvell lan works perfectly fine, but after all I did buy this board right? I should be getting dual gigabit ethernet and not just 1.


Anyone having this problem? This isn't exactly a HUGE issue with me, but I would prefer to have a fully functioning board.

Share this post

Link to post
Share on other sites

Trying going to manual settings.


I used to just use the automatic network settings but then I tried manual configuring things and it's so much better, I haven't gone back.


First make sure your router is on the latest firmware.


Now on the "basic setup" screen when you are in the router configuration menu. Put "DHCP server" to disable and apply settings.


Now in windows in the run box, type "services.msc".


Find "DHCP Client" right click properties and put startup type to "disabled".


Now also locate "DNS Client" and disable that as well.


Now go into your network connections and right-click on your connection (should be called local area connection or whatever).


Go to properties and then in the middle box click on "Internet Protocol (TCP/IP)" and click on properties button.


Then click "use the following ip address".


Now you fill in your info. For your ip use ""

subnet mask:



Now for the DNS server addresses..


In your router config page click on the status tab, near the bottom you will see "DNS 1, DNS 2, etc. Plug those values in for your connection.


Then OK your way out and reboot your computer. Maybe then it might work, not sure lol.

Share this post

Link to post
Share on other sites

I had a similar problem with my NF3 250GB board.


From one day to another it would for the hell of it not take static IP addresses anymore. Reinstall of the drivers did nothing.


I later ditched the board and got a Via-based one so I never pushed it to a solution.


Worked fine under Linux so it wasn't hardware. I concluded some NVidia driver version had damaged the TCP/IP stack, possibly the NVidia firewall thingy.

Share this post

Link to post
Share on other sites

Make sure that you have entered the correct MAC address for your LAN adapter in the Genie BIOS. The MAC address can be found on the white sticker that's on top of your port (inside the case).


I had all sorts of problems with my NV LAN adapter untill I read a post that mention the MAC address error, apparantly the adapter can loose it MAC settings after a BIOS upgrade or clearing of CMOS. After I typed the info, I haven't had any problems at all.


Kind regards,


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...