Jump to content
Sign in to follow this  
Voodoo128

All AMD X2 owners should read this. Game performance issues.

Recommended Posts

there is no solution for ppl with shutting problem in XP 64bit.

U can install amd driver and set affinity (slight decrease performance in many cases)

If u do need to set affinity, please note that some games will refuse to run in cpu1 and will only work on cpu0

 

I find that games that can run in cpu 1 generally works faster in cpu 1 then cpu0.

Share this post


Link to post
Share on other sites
installing amd driver (and CNQ disable)

the amd driver is NOT just for CnQ

then install the hot fix PROPERLY

and the issue will go away (for the ppl that have issue)

 

for the ppl that do not have issues, good for u.

(do not install the stuff mention above if u dont have issues, NONE of them help overclocking and NONE of them will give u more performance)

 

Thanks, I don't see issues -- anyone see issues in 3DMark05, or 03 that has issues in games??

Share this post


Link to post
Share on other sites

Hi there.

This reply is for vodoo128:

Just wanted you to know I experience the exact same problems as you. Regretting i spend so much money on the x2 4600+

My rig is identical to yours.

Thank you for posting this, saves me a lot of frustration.

I guess I should have bought the fx 57 instead.

X2 sucks when it comes to gaming.

 

:mad:

Share this post


Link to post
Share on other sites

I just got my computer up and running again with the stuff listed in sig. I'm wondering if I'll have to install either the patch or AMD driver if in task manager the cores aren't showing a full 100% for 2 runs of Speed 2004.

Share this post


Link to post
Share on other sites
I had this problem with warcraft 3, after i installed the AMD drivers, it completly went away.

 

Which AMD drivers are you referring to. I have this choppy performance problem is Warcraft 3 as well. And I NEED TO PLAY THIS GAME. <<

Share this post


Link to post
Share on other sites

I sometimes experience totally random stuttering in BF2. It only happens either after 3+ hours of gameplay or a specific map loads after the first map I play on. The game will turn into a slideshow and I will have to restart the computer and rejoin the map for it to go away.

 

However, sometimes the stuttering never even manifests itself during a 4+ hour session. Is this linked to the X2 gaming problem? I also have played F.E.A.R., COD2, B&W2 and HL2 with no problems which leads me to believe its something specific to BF2, anyone?

Share this post


Link to post
Share on other sites

I used http://www.appliedvisual.com/xcpu.htm to correct my issues on a AMD 64 X2 4400 SLI system. it was easy and simple. i made short cuts to everquest that were set up to run it on cpu 0 and cpu 1. i run 1 instance of EQ on each cpu with out any issues. also corrected all stutter when running 1 or 2 instances of EQ on the machine.

 

it is smooth as glass now but my games are all running on single CPU only.

 

AMD 64 X2 4400 939pin rev.E4

Gigabyte K8N Pro-SLI

2 Gig PC 3200 DDR

WDC 200 Gig SATAII

2 Rosewill GeForce 6600 PCI-E

Share this post


Link to post
Share on other sites
If it ain't broke don't fix it. I have a Manchester and a Toledo core, neither needed "fixing".

 

Faheyd... there's a setting in MBM to add some seconds to the timer for detecting CPU speed, set it to about 10 and MBM will report the correct speed.

 

Pmorocos... there's also 512K cache Toledo cores where half the cache has been disabled.

 

-pickles

 

Pickels,

That worked on the settings, click on cpu on left, scroll down to Update CPU speed X seconds after Start, change to 10, works fine!

 

Thanks,

Dylan

Share this post


Link to post
Share on other sites

Why do you edit the registry after the HotFix???

 

It enables the new settings....

 

These are the only registry edits I can find for this Hotfix----and they simply allow you to turn the hotfix off (or on) 1=on 0=off

 

"After you install the hotfix that is described in this article, you may use registry settings to disable the new performance state policy behavior. To do this, follow these steps:

1. Click Start, click Run, type regedit, and then click OK.

2. Right-click HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSession Manager, point to New, and then click Key.

3. Type Throttle for the new key name.

4. Right-click Throttle, point to New, and then click DWORD Value.

5. Type PerfEnablePackageIdle for the value name.

6. Right-click PerfEnablePackageIdle, and then click Modify.

7. In the Value data box, type 0. Make sure that Hexadecimal is selected in the Edit DWORD Value dialog box, and then click OK.

 

Note You can type 1 in the Value data box to enable the new performance state policy behavior.

8. Quit Registry Editor. "

 

Are these the correct reg hacks that folks are talking about???

 

If you are going to leave it enabled-----don't see why you'd even bother with the hack.......

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×