Jump to content


Photo
- - - - -

Keyboard and Mouse Delayed Access During Windows 7 Boot Up


  • Please log in to reply
12 replies to this topic

#1 PlanetSmasher

PlanetSmasher

    New Member

  • Members
  • 38 posts

Posted 02 July 2018 - 02:20 PM

EDIT:  I get to the point in the EDITS added at the bottom of all of my yapping....

 

My system build is Asus X99-E WS motherboard. I have a USB keyboard and mouse attached. Works fine until I install the Intel USB3 drivers.

 

After I install the drivers, the keyboard and mouse turn off, during Windows 7 start up. I have to wait around ten seconds before the keyboard and mouse come back on again.

 

I need the USB3 drivers, otherwise I’ll only have USB 2 and USB 1, plus there’s are a ton of devices that need the USB3 drivers installed. Device Manager shows a ton of device icons with exclamation points in yellow triangles. I need to install the USB3 drivers, because I have a ton of stuff that needs to work, but then It’ll slow the boot time by an extra 10 seconds.

 

I was having this problem with the keyboard and mouse before, but I didn’t know what caused it, in the past. Now, after getting Windows 7 installed onto a brand new Samsung 960 Pro NVMe M.2 drive, when I installed the Intel USB3 drivers, my boot time went from about 10 seconds to about 20 seconds, and that’s because was waiting for the keyboard and mouse to get recognized.

 

I have the latest drivers from ASUS website for this motherboard.

 

I went from mechanical hard drives straight to M.2 NVMe SSD… The difference in boot time is crazy! Until I installed the drivers…. Now it’s a really fast boot, but I have still have to wait for the keyboard and mouse to come on…

 

With the mechanical drives (four WD Raptors in RAID 5 array), boot time was a couple of minutes, because the keyboard and mouse delay was about a minute long. Now, my boot time is about 25 seconds (when I include POST).

 

I know that it seems silly to gripe about a 25 second boot time, when it used to be over a couple of minutes, before… But it is annoying, that that delay is still present, adding 10 seconds to the boot time.

 

Is there a fix for this?

 

EDIT:

 

I reread my post.  I guess I wasn't clear.  I'm asking if there is a way to get the new Intel USB3 drivers to, more quickly, without that 10 second delay, to recognize the keyboard and mouse during Windows 7 boot, on the ASUS X99-E SW motherboard?

 

EDIT:

 

My sense of time is pretty bad.  This time I actually measured how long the delay lasts before the USB keyboard and mouse are recognized....  40 seconds.  So, my boot time is actually one minute, when you go from POST through Win7 start up and then having to wait for the keyboard and mouse to become available.


Edited by PlanetSmasher, 03 July 2018 - 07:13 AM.


#2 Braegnok

Braegnok

    Nimrod

  • Folding Member
  • 1502 posts
  • Gender:Male
  • Location:Colorado USA

Posted 03 July 2018 - 09:15 AM

You can try Disabling USB Selective Suspend in your power options, see if that solves the issue.

 

 

 

 

Attached Thumbnails

  • usb-selective-suspend-windows10.jpg

Intel Core i7-9700K 

Asus WS Z390 Pro

Corsair 16GB 3733MHz

Nvidia GTX 1080 Ti FE

SeaSonic SSR-850TR

Corsair H115i Extreme


#3 PlanetSmasher

PlanetSmasher

    New Member

  • Members
  • 38 posts

Posted 03 July 2018 - 03:59 PM

I wasn't able to locate where that is.  I looked at your jpg image and my Power options doesn't look like that.  I'm using Windows 7.  I couldn't find any way to modify the way USB works from the Power Options.  I noticed, at the bottom of your jpg image that it says Windows 10, is that a Win10 dialog box?  I'm using Win7.



#4 Braegnok

Braegnok

    Nimrod

  • Folding Member
  • 1502 posts
  • Gender:Male
  • Location:Colorado USA

Posted 03 July 2018 - 04:59 PM

It's in your Power Options, https://www.sevenfor...d-turn-off.html  :thumbsup:

 

Open the control panel from the start menu.

Open power options in the control panel.

Select change plan settings next to the power plan you want to edit.

Select change advanced power settings.

Select change settings that are currently unavailable.

Set USB selective suspend setting to Disable under USB settings and then click OK to save the changes.


Edited by Braegnok, 03 July 2018 - 05:20 PM.

Intel Core i7-9700K 

Asus WS Z390 Pro

Corsair 16GB 3733MHz

Nvidia GTX 1080 Ti FE

SeaSonic SSR-850TR

Corsair H115i Extreme


#5 SpikeSoprano

SpikeSoprano

    Total Nerd

  • Members
  • PipPipPipPipPip
  • 2189 posts
  • Gender:Male
  • Location:Cape Breton,Canada

Posted 03 July 2018 - 08:32 PM

I know on some motherboards if your using w7 the usb3 drivers are loaded on the os not in bios, so to get around this you have to connect mouse and keyboard to usb2 if you want them to load faster. There is no speed difference with mouse and keyboard using usb3 imho.


CPU>I7 2600K  -MB>GIGABYTE  Z68X-UD3H-B3-MEM>16 GB KINGSTON 1600 MHZ-COOLER> HYPER 212 EVO
VIDEO>NVIDIA GTX-1070-SSD>VERTEX 3 120 GB-HD>WD 2TB- G500 MOUSE
CASE>ROSEWILL CHALLENGER W/4 120MM FANS-PSU> 750WATT-MONITOR>24 INCH BENQ

#6 Braegnok

Braegnok

    Nimrod

  • Folding Member
  • 1502 posts
  • Gender:Male
  • Location:Colorado USA

Posted 04 July 2018 - 06:27 AM

Windows 7 is an ageing platform, suffers from a number of serious failings including security deficiencies and hardware restrictions, does not meet the requirements of modern technology, nor the high security requirements needed today in 2018.

 

Choosing to run W7 today on a W10 compatible platform would be same as choosing an iPhone 3GS over an iPhone 7.   :wacko:


Intel Core i7-9700K 

Asus WS Z390 Pro

Corsair 16GB 3733MHz

Nvidia GTX 1080 Ti FE

SeaSonic SSR-850TR

Corsair H115i Extreme


#7 PlanetSmasher

PlanetSmasher

    New Member

  • Members
  • 38 posts

Posted 04 July 2018 - 07:02 AM

Windows 7 is an ageing platform, suffers from a number of serious failings including security deficiencies and hardware restrictions, does not meet the requirements of modern technology, nor the high security requirements needed today in 2018.

 

Choosing to run W7 today on a W10 compatible platform would be same as choosing an iPhone 3GS over an iPhone 7.   :wacko:

I'm just choosing not to give Microsoft all of my data, like the EULA for Windows 10 requires.



#8 PlanetSmasher

PlanetSmasher

    New Member

  • Members
  • 38 posts

Posted 04 July 2018 - 07:09 AM

 

Double post...


Edited by PlanetSmasher, 04 July 2018 - 07:18 AM.


#9 PlanetSmasher

PlanetSmasher

    New Member

  • Members
  • 38 posts

Posted 04 July 2018 - 07:10 AM

 

It's in your Power Options, https://www.sevenfor...d-turn-off.html  :thumbsup:

 

Open the control panel from the start menu.

Open power options in the control panel.

Select change plan settings next to the power plan you want to edit.

Select change advanced power settings.

Select change settings that are currently unavailable.

Set USB selective suspend setting to Disable under USB settings and then click OK to save the changes.

Thanks for that.  However, that didn't work.  The 40 second delay continues.


Edited by PlanetSmasher, 04 July 2018 - 07:18 AM.


#10 PlanetSmasher

PlanetSmasher

    New Member

  • Members
  • 38 posts

Posted 04 July 2018 - 07:12 AM

I know on some motherboards if your using w7 the usb3 drivers are loaded on the os not in bios, so to get around this you have to connect mouse and keyboard to usb2 if you want them to load faster. There is no speed difference with mouse and keyboard using usb3 imho.

 

The USB keyboard and mouse are connected to the gray USB slots (the blue ones are for 3.0 and 3.1)  I moved them to the "other" grey slots.  Got the same 40 second delay during Windows start up.

My keyboard and mouse were connected to the "gray" USB slots in the back of my computer.  The blue USB slots are for the USB3.0 and USB3.1 connectors.  I moved the keyboard and mouse to the "other" gray USB slots, but that didn't work.  The 40 second delay continues to exist.


Edited by PlanetSmasher, 04 July 2018 - 07:25 AM.


#11 PlanetSmasher

PlanetSmasher

    New Member

  • Members
  • 38 posts

Posted 04 July 2018 - 07:24 AM

I'm having trouble using the Internet, this morning.  I'm tired.  Sorry for all of the double posts and other weird mistakes.


Edited by PlanetSmasher, 04 July 2018 - 07:26 AM.


#12 SpikeSoprano

SpikeSoprano

    Total Nerd

  • Members
  • PipPipPipPipPip
  • 2189 posts
  • Gender:Male
  • Location:Cape Breton,Canada

Posted 04 July 2018 - 05:13 PM

I think your delay might be caused by some settings in the bios , go in and check everything to do with usb out, it's obvious the mb is not detecting your usb ports right away, as Braegnok pointed out if the mb is designed for w10 and not w7 this may have an impact on performance. I still use w7 myself on an older mb (6 yrs) and it will not detect usb3 until after windows loads . Also you didn't mention if you did a firmware update to the mb to make sure your using the latest one !


CPU>I7 2600K  -MB>GIGABYTE  Z68X-UD3H-B3-MEM>16 GB KINGSTON 1600 MHZ-COOLER> HYPER 212 EVO
VIDEO>NVIDIA GTX-1070-SSD>VERTEX 3 120 GB-HD>WD 2TB- G500 MOUSE
CASE>ROSEWILL CHALLENGER W/4 120MM FANS-PSU> 750WATT-MONITOR>24 INCH BENQ