Jump to content


Photo

Workstation, Folding Rig, and Photos


19 replies to this topic

#13 ccokeman

ccokeman

    ????????????

  • Reviewer
  • PipPipPipPipPipPipPip
  • 12358 posts
  • Gender:Male

Posted 04 July 2017 - 02:30 PM

Nice! 


Processor Intel Core I7 4690X  4.3Ghz
Memory G.Skill RipJaws  32GB 2400Mhz
Motherboard ASUS Rampage IV BE
Graphics  GTX TitanX x2
Power Corsair AX 1200,
Monitor ASUS PQ321Q
Cooling Liquid by comittee

Storage  OCZ RevoDrive 350 480GB  Seagate 8TB
Follow OCC on facebook.png


#14 scr4wl

scr4wl

    R34CT1V4T3D

  • Members
  • PipPipPipPipPip
  • 2941 posts
  • Gender:Male
  • Location:New Mexico

Posted 05 July 2017 - 09:50 AM

Having some weird issues with the cards.

Part of the issue comes from me trying to run this headless.

I want the fans to spin at 100%, unfortunately nvidia-settings does not work unless you have an xserver running.., that's dumb.

The work around is to start an xserver with a dummy monitor on each card, adjust the fan speeds with nvidia-settings, and them kill the xserver.

Not a big deal and I've already set up a script that does all this automagically.

Here is the problem though. When I set the fan speeds to 100% (or manually set them to anything as far as I can tell) some of the gpu's are throttled.

GPU0 always works fine, the fan can run at 100% while maintaining mem and core clocks.

Everytime at least one gpu does not work appropriately. The clocks (according to nvidia-smi) drop down to 600mhz and the power usage drops from 250 to 30W. Utilization stays at 100%.

Sometimes this only happens to one card, sometimes 2, sometimes 3,

I have not touched the power limit.

Also, I cannot manually readjust the clock speeds. I'm using 12 as the bitmask for coolbits, which i thought was supposed to give me fan and oc control, but I can only adjust the fan. (I've also tried 5 and 8)

Any ideas? I'm using newest drivers and just want to run the fans at 100% without loosing performance.

Edit:

Also, even if I only adjust the fan speed of gpu0, some of the other cards are throttled.

Edited by scr4wl, 05 July 2017 - 10:38 AM.

Generic Most Awesome Sig


#15 ir_cow

ir_cow

    I Am A Cow...

  • Reviewer
  • PipPipPipPipPipPip
  • 6120 posts
  • Gender:Male
  • Location:MT

Posted 05 July 2017 - 12:08 PM

I'm guessing you are using Linux so you cant use the Gigabyte software?


Filckr Photostream / Intel Pentium G3258 OC Guide / NVIDIA GTX 1070 OC Guide

Main Rig: i7 3960X @ 4.3Ghz, ASUS X79 R4BE, Geforce GTX 1080Ti, Intel 730(s) 480GB, 64GB DDR3 1600, Seasonic 1000w Plat.

Review Test Rig: : i7-4770k @ 4.2ghz, MSI-GD65 Gaming, Geforce GTX 770 , Corsair Force GT 240 GB, Patriot 16 GB 2400 (2x8gb), Thermaltake 750w.


#16 ARandomOWL

ARandomOWL

    Wise Owl

  • FW Team Member
  • PipPipPipPip
  • 1455 posts
  • Gender:Male
  • Location:UK

Posted 05 July 2017 - 01:12 PM

Everytime at least one gpu does not work appropriately. The clocks (according to nvidia-smi) drop down to 600mhz and the power usage drops from 250 to 30W. Utilization stays at 100%.

 

I don't have a proper solution, but you could try forcing the application clock with nvidia-smi.


4670k + GTX 980Ti -- crammed into a mini-ITX case

Arch Linux

About Me


#17 scr4wl

scr4wl

    R34CT1V4T3D

  • Members
  • PipPipPipPipPip
  • 2941 posts
  • Gender:Male
  • Location:New Mexico

Posted 05 July 2017 - 01:48 PM

I don't have a proper solution, but you could try forcing the application clock with nvidia-smi.

I've tried doing this, but I get an error saying that changing the clocks is not supported for the
Gpu's although I know it is, because it says so in the driver release. Also using 12 as the bitmask.., maybe that's not correct but i thought it was. I may try an older driver version.

If I just use two cards I can get both fans to spin 100% without throttling.

I'm going to try with three.

Also @ir_cow, yes debian

Edit: with three cards I was able to increase the fan speed on 2 cards to 100%, not a third card though. If I kept one on auto though, the other two would be fine.

20170705_160034_zpsvkle5nee.jpg

With four cards though at least one is throttled. Look at consumption of gpu1 while at 100%

20170705_162456_zpsmtiov0tc.jpg

Edited by scr4wl, 05 July 2017 - 02:57 PM.

Generic Most Awesome Sig


#18 ARandomOWL

ARandomOWL

    Wise Owl

  • FW Team Member
  • PipPipPipPip
  • 1455 posts
  • Gender:Male
  • Location:UK

Posted 06 July 2017 - 05:59 AM

I don't have a proper solution, but you could try forcing the application clock with nvidia-smi.

I've tried doing this, but I get an error saying that changing the clocks is not supported for the
Gpu's although I know it is, because it says so in the driver release.

I've done this successfully on a 980Ti on 381.22 Not sure why fan speeds can't be set through nvidia-smi :( I leave my fans on auto for now.

4670k + GTX 980Ti -- crammed into a mini-ITX case

Arch Linux

About Me


#19 scr4wl

scr4wl

    R34CT1V4T3D

  • Members
  • PipPipPipPipPip
  • 2941 posts
  • Gender:Male
  • Location:New Mexico

Posted 06 July 2017 - 07:38 AM

I've done this successfully on a 980Ti on 381.22 Not sure why fan speeds can't be set through nvidia-smi :( I leave my fans on auto for now.


Looks like I'll be doing the same. I strapped some extra fans into the case blowing directly over the two cards inside of it. Sorta helps.

I dont understand why increasing the fan speed causes some of the cards to throttle though lol,

Generic Most Awesome Sig


#20 scr4wl

scr4wl

    R34CT1V4T3D

  • Members
  • PipPipPipPipPip
  • 2941 posts
  • Gender:Male
  • Location:New Mexico

Posted 30 July 2017 - 02:19 PM

So photobucket wants to charge a whole bunch for image hosting now lol.

 

Anyway, I added a 1080 to this mess (sorry for blurry photo)

 

PqlaQDL.jpg

 

 

I was also able to figure out the fan throttling problem.., well sort of. It turns out that the cards enter a low power state as soon as x is closed (but only after running nvidia-settings ..., weird)

 

Anyway, the work around is pretty simple. You just need to throw your nvidia-settings commands into a script that starts after x starts (or just start x in the same script first) and then keep x running indefinitely with something like an empty cat command.

 

Now I can run the fans at 100% at the GPUs don't enter the low power state.

 


Generic Most Awesome Sig




Reply to this topic