Jump to content

- - - - -

Odd Printer issue

  • Please log in to reply
2 replies to this topic

#1 Eins7ein



  • Members
  • PipPip
  • 77 posts

Posted 24 February 2009 - 01:52 PM

I was working on a computer today with a printer issue. I Finished cleaning out several viruses last week and a problem arose with the printer.

I can print normal text from open office but when i try to print a web page instead of printing what is on the screen I get the HTML and JavaScript source.
I have tried updating the printer drivers to no avail. The machine and the printer are both fairly old systems (early P4).

The computer is running windows XP Home SP2 but otherwise fully up to date. The browser I was using was Internet Explorer 7 and the printer was a Hewlett Packard (don't know the model number).

#2 redtigerdragon


    Asus Xtreme Design 2009 3rd Place

  • Folding Member
  • 1061 posts
  • Gender:Male
  • Location:columbia, MO

Posted 24 February 2009 - 01:54 PM

Have you tried uninstalling and then reinstalling the drivers? Also I am assuming you tried power cycling both the printer and computer.
“Rumor has it the State of the Union is today rather than tomorrow to avoid conflicting with the Lost premiere. But my feelings towards one are pretty similar to my feelings towards the other: I’m confused by the most recent plot twists and skeptical that the writers can wrap it all up in one tidy package.” By Ezra Klein, talking about the 2010 State of the Union Address.

#3 Eins7ein



  • Members
  • PipPip
  • 77 posts

Posted 25 February 2009 - 01:11 PM

Bit of an update. THe printer model is an HP Deskjet 812c. The drivers for thios model are included in windows xp.

I deleted the printer and reloaded it but thie problem still persisted. Upon a bit further research into the problem I have found that the problem probably lies some where in IE7. I installed Firefox on the machine and was able to print normally from there.

This seems to be a problem with older HP printers and IE7. There aren't any definitive answers on the internet that I can find as to what causes this issue or a definite fix. If anyone has any more knowledge that they can share on this problem I would love to hear it.