Jump to content


Photo
- - - - -

Heatsink help


  • Please log in to reply
3 replies to this topic

#1 Narcotic

Narcotic

    Member

  • Members
  • PipPip
  • 55 posts

Posted 02 January 2013 - 02:09 PM

My parts came in for a project computer I'm building, as I'm fairly new to it, and the heatsink doeant seem to want to stretch its clips low enough to retain itself on my mobo.
Mobo: ASRock 990FX Extreme3
Processor (with in box heatsink): AMD Phenom II Black edition

More parts, but they're not important.

So, after I put the PCU in, I tried putting the heatsink ontop and it doesn't seem to fit! I'm sitting here next to it confused, afraid of putting much pressure on it.
Help!

Thanks,
-Narcotic

#2 SpikeSoprano

SpikeSoprano

    Certified Geek

  • Members
  • PipPipPipPip
  • 1380 posts
  • Gender:Male
  • Location:Cape Breton,Canada

Posted 02 January 2013 - 03:52 PM

I assume you are talking about an amd heatsink, with the clip with the 2 notches on it .I find the easiest way to install them is to lock the notch without the locking clip on the cpu housing first, then position the other side over the second notch and push down with enough pressure that it clips on. If it is the newer type it has a latch that can slide back and forth it will be  easy, if it is the older type a flat head screw driver the width if the clip works great.Just don't let the screw driver slip, make sure it is in the groove.


CPU>I7 2600K  -MB>GIGABYTE  Z68X-UD3H-B3-MEM>KINGSTON 1600 MHZ-HYPER 212 EVO

VIDEO>ZOTAC GTX 660 2 GB-SSD>VERTEX 3 120 GB-HD>WD 500+WD 250 GB-G500 MOUSE

CASE>ROSEWILL CHALLENGER W/4 120MM FANS-PSU> 650 WATT-MONITOR>24 INCH BENQ


#3 Narcotic

Narcotic

    Member

  • Members
  • PipPip
  • 55 posts

Posted 05 January 2013 - 07:14 PM

Sorry for taking so long to get back!  I honestly couldn't even get the clips over the notches, locking it or not. 
I ended up taking a screw driver to the heatsink mount and loosening them so I could bring them a bit closer.  Then I pushed the clips over, screwed the mount all the way down and locked it.  Meh, correct or not, it worked and my temp is at a decent level.

Thanks for the reply!
-Narcotic



#4 SpikeSoprano

SpikeSoprano

    Certified Geek

  • Members
  • PipPipPipPip
  • 1380 posts
  • Gender:Male
  • Location:Cape Breton,Canada

Posted 05 January 2013 - 07:29 PM

:thumbsup:  Great, any way is right so long as it worked !


CPU>I7 2600K  -MB>GIGABYTE  Z68X-UD3H-B3-MEM>KINGSTON 1600 MHZ-HYPER 212 EVO

VIDEO>ZOTAC GTX 660 2 GB-SSD>VERTEX 3 120 GB-HD>WD 500+WD 250 GB-G500 MOUSE

CASE>ROSEWILL CHALLENGER W/4 120MM FANS-PSU> 650 WATT-MONITOR>24 INCH BENQ