Jump to content


Photo
- - - - -

Razer product quality going down?


  • Please log in to reply
23 replies to this topic

#1 Locutus

Locutus

    Fortune favors the bold.

  • Folding Member
  • 1881 posts
  • Gender:Male
  • Location:Largo, FL

Posted 11 April 2012 - 10:47 PM

So I have had a few Razer products in the past, but it seems their products are markedly worse than some other brands as of late. Today my Razer Orca headset that I bought last year started going, all garbled and terrible sounding. My Deathadder died not even a month ago (which is why my birthday present was this new TT element black mouse.)

Has anyone else had trouble with Razer? Oh and my headphones aren't under warranty because they're "Earphones" and not a "Headset" just because they don't have a mic. So their warranty period is only 6 months.

Heatware - Ebay

"I can't believe I ate the entire kitten!"

 

sigimage.gif


#2 greengiant912

greengiant912

    hl2.exe has stopped working

  • Members
  • PipPipPipPip
  • 1453 posts
  • Gender:Male
  • Location:Waukesha, WI

Posted 11 April 2012 - 11:01 PM

Out of all the razer products that I have owned most of them have died within 6-12 months of owning them...

A few mice,and a headset I think I had in the past...

My buddy is good friends with the CEO, and when I met him a few years ago I told him hey man what the heck is with these shorts in the mice and stuff... I guess it was kind of a butt move but whatever..

My Website  Twitter  XBL  PSN  STEAM

MSI Z68A-GD65(G3) - Intel i7 2600k - eVGA GTX570 Classified - 16gb Gskill DDR3 - Windows 7 Professional x64

15 inch Macbook Pro with Retina Display - Apple iPhone 5s 32gb - iPad 2 - 32gb - Xbox 360 Elite - PlayStation 3 (Slim) - Nintendo Wii - Xbox One - PlayStation 4

Server+ Certified - A+ Certified - Bachelors of Science in Information Technology


#3 bp9801

bp9801

    Please press any key to continue

  • News Editor
  • PipPipPipPipPipPip
  • 8023 posts
  • Gender:Male
  • Location:Deming, NM

Posted 11 April 2012 - 11:02 PM

Overall I would say it has to vary, like with any company's products. I've seen reviews of people having no issue and then others having plenty. My BlackWidow Ultimate has been going strong for a year with no problems, well, minus a sticky + key on the numpad. I don't use it that much so I didn't even notice it until a couple months of ownership. :lol:

Intel Core i5 4690K - ASUS Z97-A - EVGA GTX 770 2GB
Mushkin Ridgeback 16GB DDR3-2133 - Samsung 840 EVO 250GB SSD - Seagate 500GB + 750GB - WD 1TB - Cooler Master SPH 1050W
ASUS Xonar Xense + Sennheiser PC-350 Xense Edition + Sennheiser HD-280 Pro + HD-555 - Thermolab BARAM 2010 - Cooler Master HAF XM

Follow OCC on facebook.png
eUYPk97.png


#4 Muchoman1

Muchoman1

    De-railer of threads, Destroyer of worlds

  • Members
  • PipPipPipPip
  • 1562 posts
  • Gender:Male
  • Location:Western Australia

Posted 11 April 2012 - 11:09 PM

i only have the naga epic. and it is now under rma due to issues with the wireless, but build quality seems fine, and i have had it for over a year (2 year warranty is nice on it)

The Hive 
               i7 3930k @ 5GHz 24/7   32Gb Corsair Dominator @ 1866MHz 
                    Asus Rampage IV Extreme    3x EVGA 670 FTW @ 1300MHz Core boost
256Gb Crucial M4 - Boot Drive  4x2Tb HDD Raid 5 - Data Storage 
CPU, Motherboard, GPU and RAM watercooled  by MIPS and Heatkiller 
Heavily Modified XSPC Cube Case 


#5 IVIYTH0S

IVIYTH0S

    They call me... General Help.

  • Members
  • PipPipPipPipPipPipPipPip
  • 20513 posts
  • Gender:Male
  • Location:Pennsauken, NJ

Posted 12 April 2012 - 03:48 AM

I've had my Razer Tarantula keyboard for atleast 4 years, and lachesis like 2 years.

"GilliumX58" DESKTOP
Mobo: Asus P8Z68-V-PRO | Processor: Intel Core i7 2600K @ 4.6ghz | CPU Cooler: Zalman CNPS9900MAXR | Videocard: MSI Twin Frozr HD7970
Memory: Patriot 8GB 1600mhz | OS SSD: SanDisk Extreme 240GB SATA | PSU: PC Power & Cooling Silencer 750W
Monitor: Samsung 30" 305T | CD/DVD: Samsung SH-S223F | Keyboard: Razer Tarantula | Mouse: Razer Lachesis

OCC Cool Club Member

 
 

 

GPU Comparison tool on AnAndTech


#6 Mercman

Mercman

    Member

  • Members
  • PipPip
  • 174 posts
  • Gender:Male
  • Location:South-Africa

Posted 12 April 2012 - 04:24 AM

my Razer Mamba is over 2 years old and is still going problem free.
[email protected](1.104V) - GIGABYTE G-POWER PRO 2 CPU COOLER - 12GB CORSAIR VENGEANCE 1600MHZ - GIGABYTE GA-X58-UD3R REV.2 - GIGABYTE GTX670 OC 2GB - THERMALTAKE TOUGH POWER 700W MODULAR - HAF-X CASE - 2TB SAMSUNG HHD (SATA) - 160GB SEAGATE (SATA) - RAZER MAMBA MOUSE- MICROSOFT / RAZER RECLUSA KEYBOARD - WINDOWS 7 ULTIMATE 64 BIT

#7 Waco

Waco

    Lab Rat 2

  • Reviewer
  • PipPipPipPipPipPipPipPip
  • 15405 posts
  • Gender:Male
  • Location:Los Alamos, NM

Posted 12 April 2012 - 04:26 AM

My Razer Arctosa black edition is still working just as well as the day I got it. I'm not gentle with it either. :lol: BluePanda uses a Lycosa and a DeathAdder and they've been perfect (with the occasional freakout of the Lycosa that's fairly well known at this point) and work just like day one.

sig.png

GTX 770 replaced with watercooled GTX780...but too lazy to change the sig.


#8 d6bmg

d6bmg

    BMG FTW!!

  • Members
  • PipPipPipPipPip
  • 4135 posts
  • Gender:Male

Posted 12 April 2012 - 04:29 AM

My Lycosa died within one year. So, I would say its normal for them. They were never better, at least for me.

boozei.gif


#9 Coors

Coors

    ????? ????

  • Members
  • PipPipPipPipPip
  • 3638 posts
  • Gender:Male
  • Location:Missouri

Posted 12 April 2012 - 05:10 AM

My original Copperhead is still alive and kicking. I can't speak for their more recent stuff over the years though.

MSI MPower Max - 4770K - 2x EVGA GTX780 ACX - 2x8GB Crucial Ballistix Tactical 1866 - 2x Crucial M4 256GB raid0 - Enermax 1020w - HP ZR30w

Sager NP9170 - i7 3720QM - GTX680m - 16GB 1600Mhz - 2x Crucial M4 256GB - 17" matte display

Shuttle SP35P2V2 - E8600 4Ghz - eVGA 8800GTX ACS KO - 2x2GB g.skill PK - Samsung 500GB - 2x Dell E228wfp


#10 BluePanda

BluePanda

    Lab Rat

  • Reviewer
  • PipPipPipPipPip
  • 2256 posts
  • Gender:Female
  • Location:Los Alamos

Posted 12 April 2012 - 05:26 AM

My Razer Arctosa black edition is still working just as well as the day I got it. I'm not gentle with it either. :lol: BluePanda uses a Lycosa and a DeathAdder and they've been perfect (with the occasional freakout of the Lycosa that's fairly well known at this point) and work just like day one.


I'm some what partial to banging my fists on the keys when something doesn't work as expected. So it working still...it's pretty good.

#11 Skidmarks

Skidmarks

    Member

  • Members
  • PipPip
  • 148 posts
  • Gender:Male
  • Location:South Africa

Posted 12 April 2012 - 06:34 AM

I recently retired my Razer Reclusa (Microsoft branded) keyboard which is 3 yrs old without any problems whatsoever but I'm thinking of reinstating it because I'm not terribly keen on my Corsair K60 with it's clickety clackety keys. I'm not generally a fan of Razers' products but their Reclusa kbd was a gem in my eyes even though it's a little large.

CPU: Intel i5 4670K
Motherboard: Gigabyte Z87X-UD3H 
Graphics: Gigabyte GTX 770
Memory: 8Gb Patriot Intel Extreme Masters 1866 Mhz 
Sound: Asus Xonar DX & Roccat Kave 5.1

Storage: OCZ Vector 256 Gb / Western Digital 1 Tb Black
CPU Cooler: Antec Kuhler 650

PSU: Seasonic X Series 660Watt
KBD, Mouse & Case: Roccat Ryos MK Glow, Roccat Kone Pure & Cooler Master CM Cosmos SE 


#12 sword_fish

sword_fish

    Geek

  • Members
  • PipPipPip
  • 620 posts
  • Gender:Male
  • Location:Philippines

Posted 12 April 2012 - 06:49 AM

i have the Arctosa & DeathAdder for more than 2 years, no problems with the KB but the Adder's left click button failed just last February tho i repaired it with success.

My Rig: Project One

2674416.png