Jump to content


Photo

The Upgrading of GARGANTUA


3 replies to this topic

#1 PlanetSmasher

PlanetSmasher

    New Member

  • Members
  • 16 posts

Posted 12 May 2014 - 06:58 PM

I originally built Gargantua in December 2011.  It is now 2014 and Gargantua still kicks butt, however, I did say I was going to make some upgrades and mod the case a little bit, and this is the story of that endeavor.  I'll start by providing a link to my original post showing the Building of GARGANTUA.

 

At the top of my article was a list of components included at the time of the original build, and the proposed upgrades I wanted to add later on.  I actually completed some of those upgrades about a year ago.  I upgraded to Windows 7 professional 64 bit, I added a second nVidia 560-TI graphics card, and hooked them up in SLI, and I added an Asus DVD optical drive.  Then, about 5 or 6 months ago, I went with an external-internal hard drive enclosure solution (connected via eSATA).  I did this because: 1) I hated Intel's SATA/RAID controller, and 2) removing the HDDs from inside the case improved the airflow out through the front of the case.  The external HDD enclosure has an excellent hardware SATA RAID controller and is connected using Marvell's eSATA controller.  I decided to stick with my array of WD Raptor HDDs.  These are SATA III HDD's set up in RAID 5.  I'll get solid state drives when I build a new machine in the future.

 

Now for the final upgrade.  I will upgrade from an i5 Sandy Bridge CPU to an i7 Ivy Bridge CPU, and change the CPU cooling from air cooled to water cooled (just because).  I modded the case to accommodate the new CPU cooler and to improve airflow in the case.

 

To start all of this, the first thing I had to do was flash the bios.  This was necessary, to accommodate the new Ivy Bridge CPU and to unlock SATA III and USB III in the motherboard.  Since I'm using an Asrock motherboard, I had to go to their web site to get the bios.  No surprises there, it's just that their instructions are barely clear enough to understand what is needed, and there are no instructions on how to actually do the procedure.  You have to guess, based on the only thing they do tell you.  “This Update requires That Update.”  You get That Update, and find that “That Update requires This Other Update.”  So, You end up downloading three updates to flash the BIOS.

 

I searched the web to see what other people did.  My search skills suck, but I found a few places where people all talked about bios flash failures and whatnot.  Based on their failures, and the very little that Asrock's web page tells you, I came up with a plan.  I know.  I risked killing Gargantua on the operating table with this upgrade.  However, I had already resigned myself to buy a new mobo if it failed.

 

This is what I did, and how it led to success.

 

On Asrock's download page for this mobo, it tells you that certain additional files are required to complete the bios flash procedure.  I got those files too.  After unzipping the zip files, I clicked the executable, and waited for instructions.  There were no instructions except for the “Finished” button that I had to clicked at the end of each one.  I did each update in the order based on Asrock's “This update (1) requires that update (2), then that update (2) requires that other update (3).  The first update actually flashed the BIOS right there from my Windows desk top.  The other two updates just installed on Windows.

 

(Some of the photos are kind of blurry.  Sorry about that.)

 

Before Operation Upgrade and Mod.

 

P1010124_zpsf14c70fe.jpg

 

Next, I shut down the machine and began to disconnect it from all of its periphery.  I took it completely apart and put the components away in there original boxes.  Yeah.  I keep the original packaging of stuff until I build a new machine, then I throw out the package with the old machine when it is replaced with the new build.  As you can imagine, I had a lot of dusting to do too.  My tools: 2” paint brush, canned air, and an ESD protected vacuum cleaner.

 

P1010128_zpsd0024cf9.jpg

 

Yeah, I'm a box hoarder.

 

Next, I modded the case.  I used a dremel tool.  Dremel tools are king when it comes to modding cases and the like.  There is nothing pretty about my modded case.  My approach to modding is purely utilitarian.  I didn't want to redo the wire management, so I didn't remove the PSU.  I just unscrewed it from the case so that I could blow it out it out with canned air and vacuum it out and clean its little corner where it lives in the case.

 

Before Dremel Tool.

 

P1010126_zpsd9bf899a.jpg

 

P1010074.jpg

 

After Dremel Tool.

 

P1010132_zpsa9566e7f.jpg

 

P1010127_zpsa8615b31.jpg

 

Actually, I had cut out the front and rear fan grills a few months after I first built GARGANTUA.  The most recent Dremel Tool action was just the top grill.

 

Next, I installed the fans and radiator to the modded case.  It is not easy to do this.  I had to do some thinking about it.  This is a four handed job, but I figured out how to do it alone.  I laid the case on its side and stuck the screws into the screw holes that I made for it.  Then I stuck the fans onto the screws, careful to align the fans so that the power leads can go through the wire management holes in the mobo tray.  Finally, I carefully aligned the radiator to the fans and screws.  I turned the screws until they “bit” into the radiator screw holes.  Once all four screws had “bitten” into the radiator, I did the counter tightening technique to finish tightening the screws (tighten the opposite corners).

 

P1010137_zps1d544632.jpg

 

I chose to mount the radiator with the water hoses to the back of the case.  I did this to leave clearance for the SATA data and power cables at the front of the case where the optical drives are, and where the SATA cables and PSU 24 pin power cable connects to the mobo.

 

Incidentally, the case, the HAF 932, only accommodates the installed 230mm fan, or can have two 120mm fans installed.  I had to mod the case to install two 140mm fans and the radiator.  As such, I was only able to use four of the eight available screws to mount the new CPU cooling system.  It's not obvious, but It's only screwed in at the ends of the radiator.  The four screw holes in the middle where the two fans meet are not secured with screws.

 

Then it came time to prepare the mobo for the new i7 and the new cooling solution.

 

P1010129_zps29e26492.jpg

 

I had to take out the old mounting bracket for the old air cooler, and put on the new mounting bracket for the new water cooling solution.

 

P1010138_zps46c3fa99.jpg

 

As you can see, that mounting bracket does not go on straight.  It seems counter intuitive, but yeah.  It goes on crooked.  I think it's because the bracket is designed to accommodate three different Intel CPU form factors: 775, 115x, and 1366/2011.  In the case of Asrock's mobo, they had several holes for accommodating the 775 and 115x form factors as well.  So, I had to consult the mobo book to figure out which holes on the mobo to use as well.

 

Next, I mounted the mobo to the mobo tray and hooked up all of the wiring, referring to the mobo book again (man, am I glad I kept all of that stuff – packaging, manuals, etc).

 

Next I put in the new CPU.  I used Ceramique II (I've been a fan of Arctic's Ceramique for years).  This time, I went with the dot of Thermal Interface Material (TIM) technique.

 

P1010141_zps3f59401e.jpg

 

In the past, I would layer on a thin coating of TIM onto the CPU die, but many TIM and heatsink makers seem to think that the dot of TIM technique is best That's because the TIM spreads evenly as pressure is applied to it while mounting the heatsink/water block onto the CPU.  The thin layer method was also very effective, but had the chance of catching an air pocket that acted as an insulator preventing heat transfer.

 

Because I wanted to use Ceramique II, I wiped off the TIM that came pre-applied to the water block.

 

P1010140_zps25074414.jpg

 

I used 99.9% pure isopropyl alcohol to clean the water block's surface.  There used to be a time when we had to polish a heatsink's surface to a mirror shine before mounting it, but as you can see in the case of this water block, it wasn't necessary.  It saved me a lot of work.  Thanks, Corsair!

 

I thought I'd have to add a SATA-to-Molex-to-3-pin power adapter to accommodate the extra fan, but it turned out that the mobo had plenty of 3 and 4 pin fan connectors.  Yay!

 

With the radiator hoses mounted to the back of the case, the Ram Slots are not blocked, and neither is the molex 24 pin power connector, and the back of the optical drives have plenty of clearance for hands to plug and unplug SATA power and data cables.

 

P1010144_zps8afa655f.jpg

 

After Operation Upgrade and Mod.

 

P1010143_zpsd39796af.jpg

 

Now for the moment of truth. Did the BIOS flash successfully, or would I have to buy a new mobo? After making sure everything was properly connected and secured in place, I closed the case and reconnected it to all of it's periphery. I booted the machine, and it did some Flash BIOS stuff. It shut down and restarted a few times as it did so. However, at some point I realized that it was caught in an infinite loop of booting and shutting off.

 

There is a “Clear CMOS” button on the back of the mobo, next to the input/out put connector ports. I pushed that button. The machine rebooted and I went into the BIOS. SUCCESS! The BIOS was updated. I had to set up the Boot Preference, because Windows 7, and my Linux partition, are installed on the external HDD enclosure which is connected via the Marvell SATA controller. Then I saved and rebooted. SUCCESS!! GRUB came on and I booted into Win7!

 

However, I had to reinstall some of the drivers for some of the hardware. I had to reinstall the nVidia graphics drivers. The onboard LAN drivers didn't need to be reinstalled, Windows recognized it and all that, but for some reason, it wasn't working. No Internet connection. I checked and re-double checked all of the network settings, and all of that. All of the settings were correct. I ended up uninstalling and reinstalling the onboard LAN diver. That didn't fix it, After a few hours of scratching my head, I ended up simply disabling the onboard LAN, in the BIOS, rebooting. Re-enabling the onboard LAN, rebooting. Bingo! That fixed it.

 

Everything is up and running, and it all works. The upgrading from SATA II and USB II to SATA III and USB III are noticeable with faster Windows boot ups, and faster game start ups. I imagine it would be even faster with solid state drives, but like I said earlier, I'll save that for a future PC build. There was also a noticeable improvement in USB data transfer rates, but with a limited number of USB III connectors, it seems I'll have to get a USB III hub.

 

P1010149_zps1542492c.jpg

 

There you have it. Another adventure in building an upper mid level gaming rig and then upgrading it, a few years later, has completed successfully (lucky me).


Edited by PlanetSmasher, 12 May 2014 - 07:13 PM.


#2 El_Capitan

El_Capitan

    Even the sun goes down

  • Members
  • PipPipPipPipPipPip
  • 6504 posts
  • Gender:Male
  • Location:Somerville, MA

Posted 12 May 2014 - 07:58 PM

Nice. I always forget about dremmeling the meshes for better airflow. It looks like your intake is from the top, and exhaust out the front and rear. Is that enough airflow to cover your HDD on the bottom?

 

You should put some covers on those fans, wouldn't want to accidentally cut your finger. Happened to me once...



#3 Black64

Black64

    Black It Out

  • Members
  • PipPipPipPipPip
  • 3311 posts
  • Gender:Male
  • Location:The internet

Posted 14 May 2014 - 02:11 PM

Neat upgrades. enjoy!


Current System

[CPU]Intel Xeon W3670 (i7-970) @3.20Ghz---[CPU Cooling]Thermalright Silver Arrow---[MOBO]ASUS Rampage Gene III---[RAM]G-Skill Rip Jaws (24GB)(6x4GB)---[GPU]ASUS GTX 780 OC---[PSU]KingWin Lazar LZ-1000---[CASE]Bitfenix Colossus Venom Edition---[HDDs]WD Dives(6.5TB total storage) and Samsung 250GB SSD(boot)---[Monitors] 3X NEC 24" LCD2490WUXi ISP Panels and 1X Seiki 39" 4K monitor

 

PC Audio System (Speakers) Triad InRoom Silver's --- (DAC) Schiit Modi --- (AMP) Emotiva MiniX-a-100 --- (Headphones) Sennheiser Momentums and Paradigm H15NC --- (Headphone AMP) --- Schitt Magni

 

 


#4 PlanetSmasher

PlanetSmasher

    New Member

  • Members
  • 16 posts

Posted 14 May 2014 - 05:13 PM

Nice. I always forget about dremmeling the meshes for better airflow. It looks like your intake is from the top, and exhaust out the front and rear. Is that enough airflow to cover your HDD on the bottom?

 

You should put some covers on those fans, wouldn't want to accidentally cut your finger. Happened to me once...

 

Yes, intake is from top and out the front and back.  There is also the side panel fan which is also intake.  I removed the internal HDDs in favor of an external HDD enclosure setup.  Part of the reason was I din't like the way Intel managed RAID and SATA, but also, air flow was pretty bad with the HDD's there.  The external enclosure has a built in hardware SATA/RAID card by Marvell, and I like how it works.

 

Yes.  I have to find something that will act as a fan guard that will not restrict airflow.

 

Thanks for your comments.

 

Thanks, Black64!  I hope that in four years, my next build will be even more ubber powered than this one.





Reply to this topic